8

When travelling to Poland, I logged in with my Google account on a Polish computer. This action somehow added Polish to my Google profile and now I simply cannot remove it.

The net effect is that a variety of sites now present themselves with my "preferred" language (which they take as being Polish), same for extensions etc.

I tried everything I could to remove it, starting with the Settings:

enter image description here

I am here trying to remove Polish but it just stays there (as in "it does not move after clicking on Remove"). If I move it down and the try to remove it, it jumps to position number 2.

Restarting the browser does not help.
Reinstalling does not help.
Deleting the profile and recreating it does not help.
Uninstalling Chrome and manually eradicate all the files which are linked to Chrome does not help.
Setting the preferred languages in my Google profile does not help (Polish is not there, I therefore assume this is a Chrome setting)

I filed a bug in Chromium but it will take ages before it is triaged. Is there a way I may have missed to remove this language from the list and end my misery?

  • 2
    @William: I did this too, I even switched to that new language as a default. I still could not remove Polish (but I could remove this new language (namely German)) – WoJ Sep 4 '17 at 19:17
  • Try removing it from your Google account. myaccount.google.com/intro/preferences – colbin8r Sep 6 '17 at 17:57
  • 1
    @colbin8r: I did that too (the Google profile I mentioned) - it is not present there – WoJ Sep 6 '17 at 17:59
  • Sorry I missed that! – colbin8r Sep 6 '17 at 18:00
  • I have the same REALLY annoying bug. In my case it's russian language. I tried disabling settings sync but didn't help either – Shine Feb 5 '18 at 22:12
1

I opened a bug report with Chromium.

The bug report is accepted and the current status is fixed.

The fix is a change in the way languages are handled in profiles and will be implemented someday, with no ETA.

A few comments from the bug report:

In go/chrome-language-controls, this is what we propose for the use case when a user deletes a language on one device that happens to be the UI language on another device: remove it from the current device but add it back to the bottom of the list if the user logs back into the device where it’s the UI language.

Claudio, I see a note in go/chrome-language-controls that you were going to add a section on this into the corresponding design doc. Let's make sure that we fix this as part of the language settings fix.

Yes we will fix this. However I'll work on it towards the end, so I don't have an ETA on it yet.

Status: Fixed We have investigated the issue. We have tried to reproduce it and were not able.

Having said that, we are planning to fix the sync issue: removing the UI language of another device and its corresponding sync problem.

| improve this answer | |
  • 1
    The issue is not fixed. I still cannot remove languages. – sonofrage Dec 25 '17 at 8:45
1

I also still can't remove language. I ended up installing plugin Quick Language Switcher

| improve this answer | |
1

This helped me:

  1. Delete Chrome from your PC.
  2. Disable location determination in Windows.
  3. Install Chrome again.
  4. Before you sync your account, check if the language is correct now.
  5. If yes, then before you sync your account, disable "setting sync" in Chrome  (setting → Sync and Google services → manage sync → "disable settings").
| improve this answer | |
-2

This happened to me after I went to HK. I tried everything but nothing worked. I had to uninstall CHROME and Install back again. I also cleared all the TEMP Files from the browser.

| improve this answer | |
  • The question describes already trying this and it didn't work. We would need more detail to know why it worked at all for you because the change is to the Google profile, which is intended to survive uninstalling and reinstalling Chrome. Also, the question involves using a different computer while your case seems to apply to the same computer. – fixer1234 Jun 29 '19 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.