0

I'm working with climatic data from a bunch of counties around the country. The data is originally on the .csv format, and when I open it, I get a different result than my co-workers. Apparently my Excel isn't recognizing properly where the decimal separator should be put and is making an odd conversion (he transforms 123,456789 (<-hundreds) into 123,456,789 (<- millions). Like I said before, my co-workers didn't have this problem, which leads me to think it's not a file related, but software-configuration related. I tried changing the format of the cell, the decimal separators (under excel options) and the tabulation options without success. I'll attach two links: the first shows the data as it should be displayed and the other one is how i'm seeing it.

How I should be seeing it
How I should be seeing it

How excel is importing my file:
How excel is importing my file

  • Are your system settings set to recognise the comma for thousands? – Solar Mike Sep 4 '17 at 19:40
  • Check your system settings under Region and language » Formats » Advanced and compare them to your co-worker – nixda Sep 4 '17 at 19:44
  • Excel also has this setting set somewhere, which you can use to override the windows settings. – LPChip Sep 4 '17 at 19:59
  • Export the data as xlsx file not as CSV, then it will not be sensitive to locale on input, or specify the correct settings while you import it (it is too late afterwards) – eckes Sep 4 '17 at 20:43
  • 1
    Somewhere, you have set the comma as the thousands separator, or you have a conflict between the thousands and decimal separators. It could be in Excel Options Advanced Editing; it could be in the text import wizard stage 3 Advanced; it could be in your Windows Regional Settings (where it is called the digit grouping symbol) for Numbers, or the WRS for Currency. They ALL should agree. – Ron Rosenfeld Sep 9 '17 at 1:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.