5

Mouse's buttons 4 and 5 operate as back and forward shortcuts in Firefox. Accidentally pressing these buttons has been common with every mouse I've owned and has resulted in severe issues with banking websites and job applications. I don't want to disable the hardware keys because these extra buttons are useful especially in games with complex control schemes.

4
  1. Type about:config into Firefox's address bar
  2. If you haven't previously disabled it, a warning page about the dangers of changing settings that you don't understand will pop up. Read it, then click "I accept the risk!"
  3. In the about:config search bar, search for mousebutton. You should find two preferences, mousebutton.4th.enabled and mousebutton.5th.enabled, both set to true. Double click each of these to set them to false.
  4. Restart Firefox probably. IDK that's what I did, don't know if it's necessary.
  • Restarting Firefox wasn't necessary, or refreshing open tabs. – user598527 Nov 14 '17 at 7:37
  • 1
    Is this windows only or was it added recently? I'm using 52.5.0 ESR on linux and those options don't show up. – Annan Dec 1 '17 at 11:52
  • 1
    doesn't work on firefox 58 on linux – DuBistKomisch Jan 9 '18 at 10:44
  • @DuBistKomisch: @Annan: Can you try creating a new boolean value for both preferences in about:config? – user598527 Jan 28 '18 at 20:43
  • @user598527 That's what I tried. Doesn't work. I ended up unbinding the mouse buttons somewhere in my X config. – DuBistKomisch Jan 30 '18 at 1:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.