24

My Del Dimension E521 running Windows 7 puts itself in sleep mode each night -- despite the fact that I have chosen a power option that specifies NEVER

Each morning I find the monitor blank and I have to hit the power button on the PC at which point Windows "resumes". The system event log shows this:

Source:        Microsoft-Windows-Kernel-Power
Date:          3/27/2010 3:21:10 AM
Description:
The system is entering sleep.

Sleep Reason: System Idle

My specific power options are:

Turn off Display          : 20 Minutes
Put the computer to sleep : Never

Is there some other setting coming into play here?

  • I am having issues with this as well on my Acer netbook. I have a feeling these settings are not as robust as they should be. I have changed mine to never while wired and it won't sleep on battery. Very annoying. I wouldn't be surprised if this is correct with an update eventually. – Zooks64 Mar 27 '10 at 18:06
25

A lot of times Dell and other companies ship software bundled with the windows install. My Asus laptop had its own power management system that played havoc with my system for days. I would check to make sure there isn't a Dell program playing games.

Also on another note have you checked the 'Advanced Settings' in the power management. There is a other options in there for sleep/hibernate what not.

  • 7
    That was it. I hadn't noticed the advanced settings. There I found a setting to hibernate after 1080 minutes (18 hours). Thanks for the info! – Howard Pinsley Mar 27 '10 at 22:22
  • 4
    Huray. thank you. That's it. 1080min = 18 hours. Wonderfull. start-> control panel -> power options -> (choose power plan) Change plan settings -> Change advanced power settings -> expand Sleep -> Hybernate after... put 0 for never. – user114205 Jan 18 '12 at 11:59
  • 1
    Had the same problem on Windows 10 and the Hibernation setting was the solution there as well – FishySwede Sep 4 '15 at 13:58
11

I had the same problem on Windows 10 and it happened when I resumed the notebook from sleep by using USB wireless mouse. It seems that sometimes Windows doesn't know why it resumed from sleep and assumes it was a remote wakeup.

However Microsoft added new hidden settings in Windows 7 which control sleep timeout after remote wakeup and the default setting is only 2 minutes!

To fix this, you need to change registry values AcSettings and DcSettings for timeout when on AC power and when on battery power. Or you can simply delete these values. They are under

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0\DefaultPowerSchemeValues\@@@

where @@@ represents Power Scheme:

Balanced: 381b4222-f694-41f0-9685-ff5bb260df2e\

High Performance: 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c\

Power Saver: a1841308-3541-4fab-bc81-f71556f20b4a\

Based on this technet thread.

  • 2
    Instead of deleting the AcSettings and DcSettings values, I set them to 0 with success. I'm hoping by leaving the values, they won't be resurrected and set by a program that notices they are missing. – Thav Jul 21 '17 at 19:08
  • To MS: what kind of consumer-oriented company, heck, even pro-oriented company, designs a power setting configuration in such a cryptic and unfriendly, undocumented, manner? Unsafe too, as Registry editing can easily glitch your machine. Shame on you! Oh, and BTW, I found the same entries on Windows 10. Hopefully this will fix my random sleeps. – JL Peyret Sep 19 '17 at 16:42
6

Same power automatic shutdown problem here. Again goto advanced power management settings, look indeed for hybernate or sleep, change the 180 minutes into 0 for meaning NEVER.

Now I hope it works. The problem was here identical on Windows 8.

  • On Windows 7 I found blanking out the number of minutes also converted to NEVER. – Jeff Sep 22 '15 at 13:45
5

I had the same problem, but my settings were all set to Never (also in the Advanced Settings).

This means that under circumstances, Windows really ignores those settings!

My solution was to go to Advanced Settings and put a setting of 14400 Minutes there, which equals to 10 days.

This idle timeout is so long that it solves my problem.

(You can find the Advanced Settings here: Control Panel -> Power Options -> Choose Power Plan -> Change Plan Settings -> Change Advanced Power Settings -> Expand Sleep)

3

I have got the same problem with my Lenovo T530 notebook with Windows 7 Professional 64 bit. The reason was the driver of the Microsoft Natural Keyboard 4000. The problem has been solved after switching off the checkbox "Allow this device to wake up the computer" at the "Power management" tab of the keyboard driver settings.

  • Wow. This one was hard to find. Thank you very much for the information. It was exactly the same here with my T430, Win 7 64bit and a Cherry Keyboard. How did you find this out? – pvorb Jul 15 '13 at 19:13
  • That was probably because Windows did think it was a remote wakup when you used the kbd to wake the notebook and used different timeout settings. See my answer for details. – Marki555 Jan 27 '16 at 8:46
1

I have had the very same problem with my Toshiba L500 Satellite, I have followed all the instructions from several different people trying to get anyone's fix to work. But to no avail, so on my very last try I noticed on the Screen Saver Settings screen that a box with a tick is situated directly next to THE "wait: "**BOX"** minutes: it says "On resume, display logon screen" so un tick this box that is the simple answer, to the entire problem. This easy fix worked for me so please give it a try and it will help you as well!

0

I have a Lenovo Y500 laptop and was experiencing the same issue. After 10 minutes of inactivity, it would just go to sleep. This is despite the settings in Power Management and Advanced Settings. The culprit was Lenovo's Energy Management program (listed as simply "Energy Management" in the Control Panel.) I removed it via Add/Remove Programs and now my laptop is back to normal.

0

Seems like this is some sort of bug in Windows. Changing the following settings (or just the sleep-related ones, if the display turning off doesn't bother you) to "1 minute", saving, then back to "Never" and saving again has resolved the issue:

Source. The cause might be (and probably is) different in some cases, but this is worth a try.

protected by Community Feb 23 '16 at 23:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.