5

I use Swedish as my input language and I switch between Swedish and Norwegian keyboard layouts using left_alt + left_shift. By default i have the "input indicator" showing SWE in the system tray. This indicates the input language, which is always Swedish, and this is not of much use to me. What I need to know is which keyboard layout I'm using, and to see that I need to bring the mouse down and hover over the indicator.

What I would like is to have the Windows7-style language bar showing SV or NO respectively so that I can check with a glance. I have followed this guide: http://winaero.com/blog/get-the-old-language-indicator-and-language-bar-in-windows-10 which claims to do what I'm describing, but instead of the SV/NO indicator I get a little keyboard-symbol:

Screenshot

Again I have to hover in order to see which keyboard I'm using. Does anyone know how to fix this?

1

I'm not entirely sure what you really want, but this is maybe what you're searching for:

In my version of Windows 10 (1703) the language bar looks like this:

Swedish input and layout

This shows my language and keyboard settings is set to Swedish. Now if I change my keyboard layout to norwegian with either alt+shift or win+space, it will instead look like this:

Swedish input and norwegian layout

I have simply added the Norwegian keyboard layout to the Swedish language here:

Settings --> Time & Language --> Region & Language --> Svenska --> Options --> Add a keyboard.

  • 1
    Thanks, but maybe I wasn't quite clear in my original question. I prefer the slimmer Vista-style taskbar: <img src="drive.google.com/file/d/0BxjIYUs-PscqZ2VJZnJkT1QwczA/…"> As you can see, the Input Indicator only displays one row, which is always SWE (the input language) regardless of the active keyboard. If I could have it display the keyboard layout instead of the input language that would serve my purpose, but so far I haven't found a way to do this. – Brundlefly Sep 9 '17 at 14:07
0
  1. Disable the "Use the desktop language bar when it's available":

Advanced settings

  1. Disable the use of small taskbar buttons (this wasn't necessary until recent Windows updates):

Taskbar properties

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.