4

This is a strange occurrence that I can't for the life of me figure out. For information: I'm running a Dell XPS 13" with Windows 10.

To reproduce the issue: I will close my lid while working on something. All my settings are set so that closing lid should make my computer go to sleep. Instead though, most of the time when I reopen my laptop it will show the "Dell" boot logo like it is waking up from being shut down, and all applications I was running were closed down in the process.

It seems to me that though I have gone into the power settings for my laptop, this is a bug somewhere else. It also is recent, and started happening in the past few weeks, perhaps after an update. Does anyone else get this error on a Dell XPS laptop running Windows 10, or have a solution to it? After searching through Microsoft's online forums, I've found nothing of value.

  • 3
    It’s possible the system crashed. Check Event Viewer. The “System“ log may contain useful information. – Daniel B Sep 8 '17 at 21:08
  • Thanks for leading me in the right direction @Daniel! It helped me find an answer to my own question. – yodama Sep 8 '17 at 23:15
3

First, thanks to @daniel-b for the suggestion to look at the Event Viewer System logs. I did that, and found a lot of indications of crashes. To analyze all the log data I downloaded WhoCrashed and had it analyze my crash dump files. It identified a driver called "bwcw1.sys". You can check out what I found by looking at this photo. I googled it and found this link which indicated it might have something to do with VirtualBox. I had recently installed VirtualBox so it made sense for the new error to pop up. After uninstalling VirtualBox now all is well, and the system doesn't randomly crash while sleeping.

  • 1
    That’s a Broadcom Wireless driver by the way. Apparently it’s for a Killer network adapter. Due to the way it tries to bypass parts of the Windows networking stack, it may be incompatible with VirtualBox. You could probably use VirtualBox without crashes if you disable or remove its helper filter in the network connection’s properties. – Daniel B Sep 9 '17 at 10:11
  • Apologies for not knowing, but how would I go about disabling the helper filter in network connection properties for the Killer network adapter? – yodama Sep 10 '17 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.