5

An issue with loading websites has suddenly developed on my Windows 10 PC. Many sites never load on Chrome because they are Waiting for fonts.googleapis.com forever: one example is Tom's Hardware. GitHub Pages sites don't work either. On Edge, these sites sometimes load with no CSS, and other times don't load at all.

I have also been noticing some other network issues lately, such as YouTube videos occasionally not loading in Chrome while working fine as an embed in Discord.

No other devices on my router have any of these issues.

How should I diagnose and resolve this?

12
  • Do you have any extensions in chrome? You could try to reset your browser or even uninstall and reinstall it. To determine what's going on you could open the developer tools in Chrome by pressing F12. Then click on the network tab and reload the page. It should tell you what elements it couldn't load. There may also be useful error messages on the console tab. – SpiderPig Sep 9 '17 at 17:54
  • @SpiderPig Resetting my browser didn't help, and incognito (where I believe extensions are disabled) doesn't make a difference. In devtools, the font from Google Fonts remains "Pending" forever. – Aaron Christiansen Sep 9 '17 at 18:25
  • Does chrome work correctly on other machines in the same network? – SpiderPig Sep 9 '17 at 18:28
  • Perhaps a DNS problem or caching problem with your ISP. Try using Google Public DNS. Also try disabling your firewall. More info. – harrymc Sep 9 '17 at 19:43
  • @SpiderPig Other machines work fine. – Aaron Christiansen Sep 10 '17 at 9:48
2

I had this problem and struggled with it for a few days. I eventually figured out that turning off BitDefender (my anti-virus program) made the problem go away.

6
  • So your workaround solution was to disabled your antivirus security protection? – Pillsbury IT Doughboy Oct 18 '17 at 2:19
  • I do actually use BitDefender - I'll try switching to something else when I have access to that computer again. – Aaron Christiansen Oct 18 '17 at 6:56
  • 1
    @Facebook, yes that's correct. Disabling my antivirus security protection solved the problem for me. After re-enabling the antivirus protection, the problem actually didn't come back as of yesterday, but I will have to keep an eye on it. If it comes back, perhaps I'll need to try other antivirus software. – plafratt Oct 18 '17 at 14:01
  • 1
    This worked! As you said, it even stills works after BitDefender was turned back on. Thanks a bunch. – Aaron Christiansen Oct 18 '17 at 18:49
  • You're welcome. The problem eventually came back for me. I sent an issue report to BitDefender. If they provide any useful response, I will update. By the way, my initial thought was to call Dell to ask them for help. I don't have a software warranty for the machine, so they wanted $89 for their assistance. No thanks. – plafratt Oct 19 '17 at 15:53
0

As you have no problems when booting in Safe mode with Network, your problem is caused by some installed product or plugin.

To identify the problem :

  • Try another browser. If the problem disappears then some plugin of Chrome is to blame.
  • Use Autoruns to disable selectively startup programs, then re-enable, until you find the product responsible for the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.