My keyboard keys have recently been malfunctioning. Sometimes, the keys do not register at all, and sometimes, it as to be pressed and held with force to register. Only a few select keys are effected, namely the: right arrow key, \, e, g, h, and 8 and 9 on the numerical keypad.

The keyboard was the factory keyboard included with my Asus X751LD laptop.

This started after I used a Java application. It is very unlikely to be a hardware issue, as the laptop was never moved or subjected to drops. Another possible factor is I have used Autosofted Keyboard Presser.

The keys function, although with lag, after startup, but stop working within a few seconds.

I have tried the following to no avail:

  • Restarting
  • Restarting in Safe Mode
  • Updating keyboard drivers in Device Manager
  • Updating Java

These sites did not help:

  • https://superuser.com/questions/436845/laptop-keyboard-occasionally-partially-not-responsive
  • https://superuser.com/questions/244860/why-thinkpad-t410s-intermittent-keyboard-death
  • https://superuser.com/questions/1141636/occasionally-unresponsive-keyboard-and-mouse

Does anyone know how to fix this?

(Was a pain typing this, makes me understand just how much I use the e key)


I tested the keyboard with a Linux live CD. First time I booted, the keys will not registrar in a notepad app unless I repetitively press them around 20 times. I rebooted into Linux again, this time the keyboard worked OK, but missed keystrokes occasionally. In both situations it was the same keys as described above that were malfunctioning.

After rebooting into Windows, the keyboard functioned like the 2nd situation above (occasional missed strokes) for around 5min. Then no amount of pressing on the malfunctioning keys could make it register.

  • 3
    Could you try these keys in BIOS setup? Besides the arrows, which work on many places there, typically there are also some text fields where you can test keys which produce characters. Also could you try external keyboard with your laptop?
    – miroxlav
    Sep 11, 2017 at 8:14
  • 1
    @miroxlav when BIOS first loaded, the arrow key was lagging, but after a few seconds all the keys worked fine when typing into a password field. External keyboard worked perfectly. Sep 11, 2017 at 8:25
  • Does external keyboard work perfectly also in Windows where at the same time your internal keyboard has problems?
    – miroxlav
    Sep 11, 2017 at 8:51
  • @miroxlav external keyboard works everywhere in Windows just like normal. Internal keyboard started having problems around 2 days ago (09/09/17) Sep 11, 2017 at 9:00
  • 2
    It might be worth booting up a Linux Live CD and seeing if the issue persists there. Since this doesn't happen in the BIOS, it might be a driver issue with Windows, or perhaps even malware (this is Java after all, it can be quite insecure). You might want to run a scan using Malwarebytes and Windows Defender just to be safe.
    – user487867
    Sep 11, 2017 at 11:48

1 Answer 1


Based on our discussion and troubleshooting in comments, you say that

  • in Windows internal keyboard has problems but external one works.

  • in BIOS Setup utility internal keyboard works.

Boot Linux Live CD or another portable OS (or at least utility) to review your internal keyboard there.

  • If internal keyboard won't work there, then it is a keyboard error.

  • If internal keyboard will work, then there was a problem in Windows and you have to clean it from malware (what is another chapter) and/or focus on driver issues.

Update: (after your update)

Based on your update with Linux Live CD experience, you confirm that the keyboard has problems regardless of the operating system. So we can rule out specific drivers, malware, other software etc. Therefore, this is most likely a hardware issue: it is either keyboard or motherboard circuits which are processing the input from the keyboard. The cheaper alternative is to replace the keyboard. If the issue still persists also with new keyboard, then it can be caused by keyboard-related circuits (or chips) on motherboard, what might require replacement of the entire board. If you have it covered by warranty, then good for you.

Before all that, you can try removing the keyboard, cleaning it and re-connecting its connector. There is some chance it could resolve the problem.

  • I have used Linux to test the keyboard, with the results in the edited question. Sep 13, 2017 at 7:54
  • @GeorgeTian – did the answer help you?
    – miroxlav
    Sep 15, 2017 at 14:16
  • Thank you for ruling out software as the problem. I've yet to clean or replace the keyboard. Sep 17, 2017 at 4:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .