0

I just upgraded my OS from Windows 7 Pro to Windows 10 Pro.
I am not able to open Visual Studio 2010 or 2012 anymore because of the following error:

Error

Any idea how to solve?

  • Have you tried to reinstall the .NET Framework?Also check that the PenIMC.dll file is in C:\Windows\Microsoft.NET\Framework64\v3.0\WPF or C:\Windows\Microsoft.NET\Framework\v3.0\WPF, which one depends on whether your installation is 32 or 64 bit and also it could be vSomeothernumber instead of v3.0 depends on your .NET version. – testeaxeax Sep 11 '17 at 12:13
  • Have you tried to repair your Visual Studio 2012 Visual Studio 2010 installation? I was unable to reproduce this problem on my Windows 10 1703 VM – Ramhound Sep 11 '17 at 12:30
  • I want to uninstall the .Net 4.7, but it does not appear neither in the programs and features and not in the windows updates so I cannot uninstall and I am stuck. I have both the 64 and 32 dll in the right locations. – KBE Sep 11 '17 at 12:42
  • I tried first to repair VS2012, it did not work so I uninstalled it and reinstall it and the error is still there. – KBE Sep 11 '17 at 12:43
  • You can't uninstall .NET 4.7 only previous versions like 3.5 via disabling the ".NET Framework 3.5" feature.Also try Microsoft's .NET Framework repair tool – testeaxeax Sep 11 '17 at 15:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.