1

I'm working on a Windows 7 machine without adimn rights. Since I love Notepad ++ as an text editor I downloaded the portable version. So far so good. Now I want to tell windows to use Notepad ++ as standard for opening txt files. Normally I would right-click on a txt file, choose open with and then go to something like default program, navigate to the exe of NP++ and that's it. However, after I selected the exe Notepad ++ does not show up in the list of programs.

Menu of programs

How can I add a default program so I can open a txt file with notepad ++? Maybe using the registry (if thats possible without admin rights)?

  • Did u select the option Always use this to open txt files when u have selected notepad++ ? – Raghavendra Sep 12 '17 at 5:19
  • Yes, but I don't see NP++ in the list of files after I selected it... – smoff Sep 12 '17 at 5:28
0

I had the same issue once for some users in our company. I found out that sometimes it messes up a registry key when you work with 64bit Notepad++ after working with 32bit Notepad++ and vice versa.

However I found the solution for this issue here and created a fix_notepad.reg file containing the following:

Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\Applications\notepad++.exe\shell\open\command]   
@="\"C:\\Program Files\\Notepad++\\notepad++.exe\" \"%1\""

It fixes the issue if you have installed the 64bit version now.

For your case: Check the specified registry key and correct the path to your Notepad++ exe. After that, it should be available in Open-with dialog again and you can set it as default.

  • I nearly solved my problem. I realized that I changed the path of the protable installation and in the registry, the old path was still there. Changing this worked! Thank you! – smoff Sep 12 '17 at 9:05
  • Here is the commands:: ftype NotepadPlus="C:\Program Files\Notepad++\notepad++.exe" "%1" && assoc .txt=NotepadPlus – Biswapriyo Sep 12 '17 at 13:32
0

As far as I know the default list is based on which programs accessed files with the respective extension through a common file dialog. So opening/saving a file might be enough.

As an alternative, try associating for extensions through Notepad++'s options. This should make it appear under "Default Programs".

The quickest way is to just click the Browse button in the screenshot and find Notepad++'s executable.

  • Thanks for your quick response. The way you describe clocking the browse button is what I tried. I get the same picture before and after I selected the NP++.exe. I treid to associate the extention in Notepadd++'s options, but it changes nothing. – smoff Sep 12 '17 at 5:27
0

Select on any of the file you will want to open with Notepad++, that is, the files with .txt extension, then you right-click on the .txt file, choose open with and then you select choose default program..., you should have this window coming up Open with

If you don't have notepad++ shown among your Recommended Programs and other Programs, click on the select the Browse button, but ensure you check the Always use the selected program to open this kind of file.

If you have you notepad++ install normally, the moment you click on the browser button, a window should pop up for you, there you should navigate to your C: drive => Program Files (x86) => **Notepad++ => Notepad as shown in the image below

notepad

After which you click on open.

This should solve your problem.

  • This is exactly the way I'm used to go. However, if I click on "browse", select notepad++.exe it dows not show up in the "open with" window. In other words, before I slect nopepad++.exe and afterwards, the list of programs is exactly the same. BTW: Since I don't have admin rights, I cannot install notepad++. So I use a portable version, which, in general, works fine. – smoff Sep 12 '17 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.