16

We have some weird behavior on a lot of machines here – computers running Windows 10 x64 and Windows 8.1 x64. Using Internet Explorer we face no problems when visiting different websites, but Chrome is very, very slow when trying to access HTTPS websites, and its all HTTPS websites, but only in Chrome. We tested on fresh Chrome installs, even without any users logged into it or extensions installed.

The only thing in Internet explorer which is slow? The download of Chrome. On one machine I even tried to download Chrome through Ninite, but that was also slow!

I have tried scanning the affected computers with Malwarebytes and Windows Defender, but nothing shows up. In every other way the computers work fine, so I don't expect there to be any viruses or the like. I've tried changing DNS settings, reinstalling network drivers, etc., but nothing helps.

Do you have any suggestions?

  • Does this happen for only chrome? Is there any SSL certificate issue? Try to delete Chrome profile folder and restarts Chrome. – Biswapriyo Sep 14 '17 at 11:27
  • @Biswa - Only chrome or other browsers based on the chromium framework. Deleting the folder does not help, but I'm having a hard to understanding why deleting that folder should fix it, since the browser is freshly installed on the computers. – Daniel Jørgensen Sep 14 '17 at 11:37
  • 2
    Suggestions: (1) Clear %TEMP%, (2) Disable firewall and antivirus, (3) Try Google public DNS, (4) Delete CRL and OCSP Caches by certutil -urlcache * delete. Question: Is the load slow only the first time and the second load in same session is faster ? – harrymc Sep 18 '17 at 13:14
  • 3
    You can investigate with chrome://net-internals/#events , filter an https site that's slow and see what's happening – HoD Sep 20 '17 at 7:50
  • 3
    please in Chrome enable developer tools and switch to network tab. Then open a HTTPS website, you should see a timeline with everything that chrome does, and you should be able to see if the problem is with DNS, network or something else. – bocian85 Sep 20 '17 at 9:49
0

From my experience, resetting winsock may help. This clears all IP related settings, and sets the network adapters to their default configuration.

PLEASE NOTE THAT ANY STATIC IP'S SET WILL BE CLEARED

You can run this with the command: netsh winsock reset After running the command, restart the PC.

It is said that windows newer than windows 7 messes with the winsock related files causing issues with Chrome/chrome driven browsers.

Hope this helps!

protected by Ramhound Apr 17 at 12:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.