When a process is selected on the Details tab of Windows 10 Task Manager and you scroll the list so, that the selected process isn't visible anymore, after the next list update it auto scrolls the list to make the selected process visible again.

This is an extremely irritating "feature", since it basically makes scrolling impossible when the selected process continuously jumps from top to bottom and back (for instance, you sorted the list by CPU consumption and the process consumes 0% at the one moment and 100% at the next one).

Moreover, there is no apparent way to clear the selection. Clicking outside the list does nothing and pressing Esc just closes the Task Manager app.

And even more to it, even if process doesn't jump at all but you scroll and it becomes out of the view, the list would be eventually scrolled to it in a few seconds.

Does anybody know how to disable this "feature"?

  • If you're focused on a specific process why don't you sort by Name or PID instead? Problem solved.
    – joeqwerty
    Sep 15, 2017 at 15:41
  • @joeqwerty: I never said I'm focused on a single process (especially when there is a need to scroll the process list for some reason or another). What makes you think so? Sep 15, 2017 at 15:51
  • You said in your question that this happens when you have a specific process selected. Your selection is focused on that process. You may not be "focused" on that process from a thought/mental aspect, but your selection has that process focused. That's what I was getting at.
    – joeqwerty
    Sep 15, 2017 at 15:54
  • @joeqwerty: I see now. But consider the case: you selected a process, did what you need and forgot about it and Task Manager. You returned to it in an hour with the different task in your mind. That process is still selected. You sorted as you need, started scrolling and boom it undermines all your effort by stubbornly scrolling back to that process. This is even not talking about the case when you might have been selected a random process just mechanically, not intending to focus on it. Sep 15, 2017 at 16:02

2 Answers 2


Pressing Scroll Lock on your keyboard while the Task Manager dialogue is open seems to enable or disable the automatic scrolling. I do believe that closing the Task Manager undoes or resets the effects of the keystroke, however.


I had the same exact problem what I did is I pulled my USB mouse adapter out and then put it back in and it stopped scrolling. I really hope this works for you I tried so many different things I did a system restore I did a reset but this team to do the job.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.