I've got 3 machines on my network, all running Windows 7.

None of them can ping each other, either by name or IP address. (And because of this, they also can't see each other on the network, can't see shares, can't remote desktop, can't see any homegroups, etc.)

  • They are all on the same workgroup.
  • They are all connected to the same wireless, WPA2 secured network.

They all worked together nicely until I added a password to my wireless network. After that, and after reconnecting all the machines to the password-protected network, they can't see each other.

Any ideas what could be wrong?

  • What error do you get? Are you pinging by name or IP address? – SLaks Mar 28 '10 at 16:48
  • what are their IP addresses and subnet masks? – David Fox Mar 28 '10 at 17:04
  • Error I get while pinging is "destination host unreachable" – Judah Himango Mar 28 '10 at 17:30
  • My IP address is, other machine IP address is (and the other machine is .104) – Judah Himango Mar 28 '10 at 17:30
  • If you ping the IP Address, what happens? – SLaks Mar 28 '10 at 17:47

Either your wireless AP or your clients have a bug in how they're handling the WPA2-PSK group (multicast/broadcast) keys. Because of this, ARP broadcasts aren't getting through from one client to another. Without ARP, they can't learn each others' wireless MAC addresses, so they can't address the 802.11-layer headers of the ping frames.

Enter static ARP mappings between two machines and see if they can ping each other -- I'll bet they can.

If you enabled WPA2 "mixed mode", where both WPA[1]-style TKIP and WPA2-style AES-CCMP are both enabled, see if your problem goes away when you switch to pure WPA2 (AES-CCMP only). Hopefully you don't have any TKIP-only clients that this excludes. Mixed mode is a little tricker than pure WPA[1] or pure WPA2, because it requires a TKIP group key but AES-CCMP pairwise (per-client unicast) keys.

Make sure your AP's firmware and your client machines' OS, wireless software, and wireless drivers are full up to date, in case your vendors have fixed their bugs.

Make sure to buy Wi-Fi certified equipment. Look for the Wi-Fi certification logo. This is why the Wi-Fi Alliance exists, to make sure that 802.11-based products follow the specs correctly and interoperate properly.

  • sounds sane for me, would explain why icmp worked before the wifi get into the way as well – akira Mar 29 '10 at 6:28
  • I'm not sure how to enable WPA2 mixed mode, but I assume it's some router setting I'll have to find. I'll check. Thanks for the answer, if it leads to a fix, I'll mark yours as the answer. – Judah Himango Mar 30 '10 at 14:40
  • 2
    Spiff, I switched to TKIP/AES mode (mixed mode I guess) in my router's wireless security setting. That seemed to fix the problem. Thanks! – Judah Himango Apr 19 '10 at 3:23
  • 2
    Well, this may be the first time I've heard of switching from pure WPA2 to WPA2 mixed mode solving this problem, but I'm glad you found something that worked for you. – Spiff Apr 19 '10 at 5:54
  • 1
    Well, it started acting up again. I changed it to AES mode. Whammo, it's working again. Heh. Thanks again. – Judah Himango May 9 '10 at 22:28

i would rather check the firewall of your windows7-machines.

follow this to allow windows7 to react on icmp-packets.

(it is unlikely the router will block icmp-packets from the lan to the lan).


This pointed me in the right direction. Switching the router from WPA-2 to WPA+WPA2 allowed my windows 7 machines to ping each other and the home network to function again.

It broke when I received a new modem/router from my ISP so I imagine the issue is with the router, rather than the windows machines.

  • BTW I have a plus.net Thompson Gateway router TG585 v8 firmware version – Barn Feb 3 '11 at 23:27

If your wireless clients don't see each other but wired clients can see each other, try unchecking or disabling AP isolation.


Assuming they're on the same subnet (192.168.0.xxx with a mask of, then I'd check your router settings. A lot of routers block ICMP (ping).


"Unreachable" usually means that it can't figure out where to send the ping, rather than saying something didn't respond.

  • Ok. Where do I go from here? – Judah Himango Mar 30 '10 at 14:50

To be sure, i suggest you reboot all the machines & try again. Look into event viewer on each machine for some clues. Execute tracert on the command prompt to the ip addresses & see what you get.
Also, turn off any firewall so you can better isolate the issue.

  • I've already rebooted the machines. I'll check tracert and the event log. – Judah Himango Mar 30 '10 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.