0

I needed to use VMware Player for a couple different things and I have no network connection: there is no available driver. Obviously I can't connect to the internet to download a driver (directly in the driver installation process) though I can obviously drag and drop driver files if need-be from the host OS easily enough.

  • Yes, the device is connected.
  • Yes, I've attempted to install the driver by manual selection (AMD-8111 10/100 Integrated Ethernet Controller is the only one I can select).
  • Yes, I've tried all the various network devices available from VMware Player and restarted Windows XP 64 bit before attempting to install a driver.
  • Yes, I've installed VMware Tools and manually pointed the device installer to it's directories without success.
  • Yes, I've spent a few hours trying to find a working answer around the web.
  • The device instance id is PCI\VEN_1022&DEV_2000&SUBSYS_20001022&REV_10\4&47B7341&0&0888.
  • I've manually searched for any INF files that contain "vm" in the file name without success.
  • I've looked in the VMware tools directory for INF files without success.

Am I missing something or what? The host system is Windows 7 64 bit.

1

Thank you very, very much you saved me a LOT of grey hairs and many many hours of digging around with absolutely no clue at all.

I had the exact same issue since I was converting from Oracle VirtualBox to VMware Workstation via the OVA File Export/Import. My Guest OS (Windows 10 x64) was not recognized correctly by VMware Workstation - it was declared as "Other OS" and did not show any network adapter at all.

I tried NAT and Bridged network mode but both were useless since I did not get any network adapter in my Guest OS - when I take a look at the Device Manager inside my Guest OS it just displayed "Ethernet Controller" in the section "Unknown Devices" - no manual installation of the device driver was possible.

After switching the Guest OS from "Other OS" to "Windows 10 x64" the corresponding network driver was installed automatically and the network driver (Intel Gigabit Network Connection) was shown correctly in the Device Manager.

| improve this answer | |
  • I'm glad I was able to help! Being thorough is critical, I often find that I missed something somewhere. The most important thing is that when I come across an answer is to make sure I post the answer online as to save someone else those hours or days. If you ever get stuff a good night's rest will get your mind fully charged and ready. Always try what you haven't and be persistent! 🙂︀ – John Aug 18 at 10:06
  • If you plan on thanking someone, please do it via chat or commenting. Please do not do it in an answer. Good to know that you found a solution. – Razetime Aug 18 at 12:59
0

When I set up the virtual guest I already had the virtual drive file with the OS already loaded on it though from an earlier/different install of the host OS. This means that when I setup the guest OS it had no way to detect the hard drive image and thus the operating system version. So by default it opted for Windows XP (not 64 bit*). After setting it up I removed the default new drive and setup the old/still working virtual drive. After I shut it down and changed the operating system version. Since I loathe people who don't bother to post a working answer after they've figured it out here is a screen shot to help aid those who encountered the same issue:

VMware Player fix for missing network driver

This also fixed another miscellaneous missing driver. By default it uses some Intel network driver and it automatically detected it after I corrected the VM's OS version.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.