1

I am attempting to control the display language for metro style apps (modern UI), system wide. I want all the metro apps to use English as the display language.

In 'Change your language preferences', I have added Polish, Swedish and Danish in that order (Correct, I have deliberately not added English, as I will explain at the bottom).

In the 'Advanced settings', I have selected English under 'Override for Windows display language'.

At this point, I expect to see English text throughout Windows as well as in all apps (at the very least, in the Windows bundled metro apps). However, the metro apps are displaying Polish text.

Changing the order of the languages in 'Change your language preferences' has an immediate effect, so the display language for the metro apps is apparently controlled by the order of these languages. The language at the top of the list is used as the display language for metro apps, regardless of the 'Override for Windows display language' setting. And there does not seem to be a 'Override for metro style app display language' setting anywhere.

I am using Windows 10 version 1703 (build 15063.608).

I apologize for the lengthy question, but I figured I should be clear about what I am attempting; the apparent core of the issue; and why certain work arounds will not accomplish the desired effect.

Has anyone been able to resolve this issue?


Why I do not just add English to the list of preferred languages:

I do not want to add English to the list, because Polish and English have the same keyboard layout. The only difference between the two, is additional support for special characters that can be accessed through Alt+[key] with the Polish layout. No features of the English layout are missing from the Polish layout, so using the Polish layout covers both English and Polish input needs. I change keyboard layout (Alt+Shift) frequently and i do not want to be forced to scroll through a list of keyboard layouts that includes a layout that i will never use.

  • If you want the display language to be English then you need to add English. – Ramhound Sep 16 '17 at 13:17
  • I don't think there is a way to do it. Microsoft does not seem to understand this use case. I'm now trying to unlearn decades-long habit of alt+shift in favor of alt+shift+(1,2,3) for specific layouts – Alexander Abramov Jan 24 '18 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.