1

I have bunch of .Xls file. But we have upgraded to Excel 2016 recently. How can I open .xls file with Excel 2016? It gives me an error message "Excel cannot open the file .xls because the file format or file extension is not valid"

I tried the following few things: But it still doesn't work. Any help is greatly appreciated.

go to file tab-->options-->Trust center-->Trust center Settings-->Protected View-->under this tab uncheck all the boxes

or this...

file tab-->options-->Trust center-->Trust center Settings-->File Block Settings-->under this tab uncheck all the boxes

2

Unfortunately, none of the above worked for me. I'm on Win 10 with Excel 2016 (32-bit). The only thing that worked for me was to open the workbook using the Excel VBA Editor (ALT+F11). You can type the following at the immediate windows (CTRL+G if it doesn't display initially):

application.Workbooks.Open FileName:="FILENAME.XLS", CorruptLoad:=xlExtractData

Obviously replace FILENAME.XLS with the file name (and optionally path) of the file you are trying to open.

This at least allowed me to view the worksheets and the data. The files I needed to open only contained data. I presume this would not recover any formatting, charts, etc...

Note that an article on SpiceWorks suggests this is due to an update from Microsoft causing the issue. I work in a very tightly controlled environment so was not able to uninstall the update myself.

Hope this helps someone else out.

0

Right click on each file, click Properties On the General tab click Unblock Click OK

0

This worked for me in Windows 10:

  1. Right Click on the file with the .xls extension.
  2. Go to Open with from the drop down menu.
  3. Next click on Choose another app from the 2nd drop down menu
  4. A dialogue box will open with "How do you want to open this file?" at the top
  5. Click on More apps in blue with a down arrow next to the words.
  6. Scroll down to the bottom of the list of apps it gives you
  7. Click on Look for another app on this PC
  8. Find the file EXCEL.EXE (See info below on where to find this)

C: Program Files (x86) > Microsoft Office > root > Office 16 > EXCEL.EXE

Click to open the EXCEL.EXE file and your .xls file should open right up. This will also associate Excel 2016 with all .xls files on your computer or any new ones you come accross in the future. You can confirm this file association in the Default app settings in your Windows Settings. I hope this helps!!

0

Open the Excel 2016 application first then open the xls file using Excel instead of windows explorer. This approach works for me.

-2

Please try this first:

-- Open a blank book in Excel 2016, then save it in an old".xls" file format, then close Excel.

-- try opening this file and see if there is a problem. Also, instead of double-clicking on the file to open it, try first running Excel 2016, then open the file inside. do both worked?

now, if you have succeeded in opening this file you have just created, it means you have other problems with your old files.

protected by Community Feb 10 at 13:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.