1

I'm currently using openSUSE Tumbleweed (with KDE Plasma 5, if that matters).

I use htop to monitor system resources, and lately I get a messed layout, especially on the topmost area of the screen. The information is not easily readable, and it is not that useful in this state.

enter image description here

How can I solve this?

4

It was caused by ncurses.

To resolve this, I had to add the following line to my ~/.bashrc:

export TERM=linux

Reference on openSUSE forums.

  • 1
    With TERM=linux I get font problems instaed. A value of xterm-color worked for me. – OrangeDog Jan 9 at 13:23
0

Perhaps resetting config to default will help:

mv ~/.config/htop/htoprc{,.bak}
rm ~/.config/htop/htoprc
touch ~/.config/htop/htoprc

Try htop afterwards. If it didn't fix it you can restore your old config file:

mv -f ~/.config/htop/htoprc.bak ~/.config/htop/htoprc
  • Thanks for the suggestion, but unfortunately this doesn't solve my problem. – Sekhemty Sep 18 '17 at 9:57
  • Which version of htop do you have? And do other ncurses-based programs function normally (like iftop, ncdu, ...)? – HoD Sep 18 '17 at 11:05
  • I have version 2.0.2 – Sekhemty Sep 18 '17 at 11:20
  • Can you check in settings which bar is active? F2 -> Left Column The default is CPUs (1/1) – HoD Sep 18 '17 at 11:59
  • I have CPUs, Memory and Swap – Sekhemty Sep 18 '17 at 12:08
0

I solved this problem by adding an alias for htop in ~/.bashrc:

alias htop='TERM=xterm-color htop'
New contributor
feilong is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.