126

I have got a new installation of windows recently. Now when I do unpin items from taskbar that were there (IE, Edge, Explorer), they do come back after restart. A pinned chrome does not disappear though e.g.

Anything to fix this issue?

P.S. Just created a new user, and he has the same problem

P.P.S. Sign out is enough to get it back, no full restart needed

2
  • Does anyone know what causes this? Is it actually a Windows Update? If so can we band together and lynch the person who made this decision? – RJFalconer Sep 29 '20 at 17:47
  • 1
    I think it's domain policies, at least in my case – Ilya Chernomordik Sep 30 '20 at 18:18
204

I had the same problem. Nothing works.

Finally, I found the XML file in my profile:

%LOCALAPPDATA%\Microsoft\Windows\Shell\LayoutModification.xml

The items were listed here in this section:

  </DefaultLayoutOverride>
    <CustomTaskbarLayoutCollection PinListPlacement="Replace">
    <defaultlayout:TaskbarLayout>
      <taskbar:TaskbarPinList>
-- items were here - removed
      </taskbar:TaskbarPinList>
    </defaultlayout:TaskbarLayout>
  </CustomTaskbarLayoutCollection>

Maybe this will help someone.

8
  • I have found items in there as well, will try to delete them and see if it works – Ilya Chernomordik Jan 16 '18 at 8:35
  • I tried removing the items and even the file, but not work... Windows 10 Pro 10.0.16299 – Kelvin Hu Sep 4 '18 at 5:33
  • 1
    That file doesn't exist on my hard drive, nor does a text search for CustomTaskbarLayoutCollection or DefaultLayoutOverride in my AppData folder yield any results... there is a DefaultLayouts.xml file in the location you specified, but it seems to contain data for the default start menu layout (which I don't use, since ClassicShell is so much better). Any other options where that setting might live (on Win 10 Pro)? – Amos M. Carpenter Dec 25 '18 at 0:44
  • 2
    In my case I had to edit C:\Users\Default\AppData\Local\Microsoft\Windows\Shell\LayoutModification.xml – TrevorWiley Sep 10 '19 at 13:11
  • 1
    This worked, thanks! I commented out the entire <CustomTaskbarLayoutCollection> section. To do this, type <!-- right before the <CustomTaskbarLayoutCollection> line, and then type --> after the </CustomTaskbarLayoutCollection> line. – bitsmack Nov 13 '19 at 7:11
16

I managed to find a solution on Microsoft Technet.

I've also, personally found another way around it:

  1. Open the explorer or the run prompt and go to %userprofile%\AppData\Local\Microsoft\Windows\Shell
  2. Edit the LayoutModification.xml file using the Notepad or some other text-only editor
  3. Locate the <taskbar:TaskbarPinList></taskbar:TaskbarPinList> entry and in that entry remove the line <taskbar:... /> adding Edge
  4. Save that file and reboot.

This will not survive "major" updates to the system/Edge such as the April 2018 one, but you can simply do the above again to get rid of that impolite shortcut.

1
  • 2
    Hey James, welcome to Super User. Just an FYI, when linking to a solution on another site, it is preffered to restate the salient points of the linked solution in case the link becomes dead at a later date. Looking forward to seeing more from you in the future. – Cliff Armstrong Aug 22 '19 at 16:28
6

It appears that this was some corporate policy from domain that have done that and it's not possible to turn off that easy, but anyway, domain rules are a possibility when this happens.

5

First, go the following paths:

  • C:\Users\username\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar
  • C:\Users\Public\company name\TaskBar (if this path doesn’t exist, ignore it)

Delete the items that you don’t want to show in taskbar.

Restart computer to see the result.

If no help, backup personal data, remove current account and create a new one, maybe your account is corrupted.

Good luck

6
  • 1
    Thanks for the answer, the items are not there after I unpin them. They come back after restart though (interestingly enough Edge shortcut is not there but still is pinned). New user got the same probelm – Ilya Chernomordik Sep 19 '17 at 6:55
  • when those items come back, please try to delete them directly from explorer path rather than unpin. – Origami Sep 19 '17 at 7:58
  • There is a .bat file which could clear all pinned apps on taskbar, you could have a try. How to Reset and Clear All Pinned Apps on Taskbar in Windows 10 tenforums.com/tutorials/… – Origami Sep 19 '17 at 8:00
  • Deleting items directly did not help unfortunately and I'd prefer not to run bat files on init if possible – Ilya Chernomordik Sep 19 '17 at 8:34
  • 2
    This began after the clean installation of Windows on my machine, so I doubt it's malware, but a good question is how to uncorrupt it? :) – Ilya Chernomordik Sep 19 '17 at 13:54
2

It's the default behavior. I was searching far and wide for the solution to this issue, and then I realized something:
The file LayoutModification.xml was simply not there.

So rather than try to look elsewhere for those stubborn icons, you could just remove them by creating your own file:

  1. Go to the path where the file is supposed to be: %APPDATA%\Microsoft\Windows\Shell\
  2. Open a text editor of your choice and create an empty file with the name LayoutModification.xml.
  3. Paste the following layout in(reference):
<?xml version="1.0" encoding="utf-8"?>
<LayoutModificationTemplate
    xmlns="http://schemas.microsoft.com/Start/2014/LayoutModification"
    xmlns:defaultlayout="http://schemas.microsoft.com/Start/2014/FullDefaultLayout"
    xmlns:start="http://schemas.microsoft.com/Start/2014/StartLayout"
    xmlns:taskbar="http://schemas.microsoft.com/Start/2014/TaskbarLayout"
    Version="1">
  <CustomTaskbarLayoutCollection PinListPlacement="Replace">
    <defaultlayout:TaskbarLayout>
      <taskbar:TaskbarPinList>
        <taskbar:DesktopApp DesktopApplicationLinkPath="%APPDATA%\Microsoft\Windows\Start Menu\Programs\Accessories\Notepad.lnk" />
      </taskbar:TaskbarPinList>
    </defaultlayout:TaskbarLayout>
 </CustomTaskbarLayoutCollection>
</LayoutModificationTemplate>

Notice the PinListPlacement="Replace" on line 8. That'll remove the old icons you have(bye bye annoying Edge and Store icons!) and add any you specify in the list(like the Notepad one I have here). Note that this doesn't affect the icons that you explicitly pin to the taskbar(those are controlled by the %APPDATA%\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar folder).

Note: If you find the need to add any more icons, don't trust names in Explorer! Go to the General tab of the shortcut(.lnk file) you want to add and copy the path from there. The Explorer tends to have different names for some folders - mine had a name of "Windows Accessories" for a folder and a path name of just "Accessories". If you put the wrong path in, your icon won't show.

0

I was searching for the similar solution to prevent Opera automatically pinning itself to the taskbar each run. The solution provided above didn't work for me as both LayoutModification.xml in "default" and my user folders didn't contain such sections. I found working the suggestion in the following article:

https://www.thewindowsclub.com/prevent-pinning-or-unpinning-of-taskbar-items-in-windows-10

I added the "HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Windows\Explorer\NoPinningToTaskbar" DWORD32 option and set it to 1 then restarted Windows Explorer via the Task Manager and voila - after the next Opera start and exit it was not pinned anymore. But note that along with that "pin to taskbar" context option disappears as well from the context menu so if you need this option later again enable it back.

-3

go to C:\Windows. search for edge. there will be a folder name something like MicrosoftEdge. either rename or delete this folder. restart computer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.