9

My laptop arrived an hours ago. one of the main reasons I considered purchasing this laptop instead of HP was an app called battery health charging which lets me limit my charging to either 60% or 80% since I keep my laptop for a long time it's Important to me.

On the Asus page about this app there's no button or anything for downloading.

I tried searching my PC and found nothing. The driver page for this laptop has nothing either.

Can anyone help me install this Software? My model is made in 2017 (7200U) just like the article said! it's a ZenBook too apparently

Apparently Asus said that it's only supported on some models and not all unlike what they said on the article so they basically lied :( the link doesn't work and all options are grey unless I change the registery which only makes them available but not work

1
  • I would contact Asus support.
    – Ramhound
    Sep 19, 2017 at 10:33

6 Answers 6

6

Here is the link from the ASUS download area

http://dlcdnet.asus.com/pub/ASUS/nb/Apps_for_Win10/ASUS_Battery_Health_Charging/ASUS_Battery_Health_Charging_Win10_64_VER100002.zip. NOTE, I could not find it under the list for a UX430UA, but I saw it for a UX370UA

3
  • I'll give that a try too! thanks. although the other one didn't work! Oct 19, 2017 at 8:10
  • PS sorry for downvote I do't see why you're downvoted, it's not me. Everything on Superuser is downvoted anyway :D this website is sometimes like ISIS of forums! Oct 19, 2017 at 8:10
  • 1
    thanks! but i still have the issue that I had with the other file. they're grayed out. and i cant choose anything Sniff Oct 19, 2017 at 8:12
4

The battery health charging application is now directly available in the Microsoft Store.

But if your device is unsupported, it will do nothing.

2
  • To Check your Asus laptop model compatibility, go to the provided link. Supported models list, is under See System Requirements.
    – Omid
    Jan 9, 2020 at 23:41
  • Here is the list of supported laptop models. Apr 30, 2020 at 15:32
3

My laptop is ASUS UX410UAK with Win 10.

For me it worked following these steps:

  1. Download the ZIP from the link provided by Brian.
  2. Install the ASUS Battery Health Charging app. (The options are grayed.)
  3. Edit the registry following Viserion's advice from another question, namely:
    1. With regedit go to HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\ASUS\ASUS Battery Health Charging
    2. Modify the CheckSupported value from 1 to 0
    3. Reboot your system
2
  • 1
    It doesn't actually work, it just lets you change the options, but if you leave it plugged in it goes up to 100% Jul 24, 2018 at 9:02
  • In my case, even if I change it and select Full Capacity Mode and plug in, it remains stuck at 80%.
    – arun
    Dec 25, 2020 at 6:16
1

You guys need to find Asus Install (Desktop App) and install everything in it including Asus Batterry Health Charging.

(I tried to install ASUS Battery Health Charging only but the app not working properly).

3
  • There's no Asus battery health charging in asus Install, only useless nonsense :( Jan 12, 2018 at 19:06
  • Here (myAsus): microsoft.com/en-us/p/myasus/…
    – Dani
    Dec 16, 2019 at 8:22
  • MyAsus is essentially useless for GL702VS.
    – arun
    Dec 25, 2020 at 6:17
1

You must install ATK package in order to properly function.

ATK Version V1.0.0050 2016/10/1711.27 MBytes ATKPackage ATKACPI driver and hotkey-related utilities Fix Unquoted Service Path issue. Thanks for Yunus YILDIRIM (@Th3GundY), CT-Zer0 Team (@CRYPTTECH)

You can find it in the asus driver download page.

2
  • Thanks a lot for your reply. But my model only has the 1.49 version! The other version is only available for the 8th gen uar model (i think uar is 8th gen right?) Jan 12, 2018 at 17:58
  • I Uninstalled the current one and used the UAR one, (atk pakcage), THe options are still greyed out @feña-hazelmalkav Jan 12, 2018 at 19:31
-1

Please try this download link and see if it works in your laptop: https://www.asustreiber.de/downloads/download/45-asus-tools/767-asus-battery-health-charging

5
  • Thanks a lot! are you sure this website is safe? Sep 19, 2017 at 10:45
  • I did and it didn't work. I can't select an option they're only there Sep 19, 2017 at 11:09
  • I changed the registry and now it works! Strange that it doesn't come with it or well.... let you use it without registry edit! I'll know if it woks in 10 hours though :P Sep 19, 2017 at 13:02
  • Great to hear that. I'm not quite sure who owns asustreiber.de but I think it has been along for quite some time so it's probably ok. What did you change in the registry to make it work?
    – Gerald
    Sep 19, 2017 at 16:11
  • It didn't work :( @Gerald Sep 19, 2017 at 17:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .