0

I am having a strange problem on a Windows 7 machine in that I cannot ping unless I do it from a command prompt that has been run as Administrator. When I try to ping as a standard user and this is the error I get:

  > ping 127.0.0.1

  Pinging 127.0.0.1 with 32 bytes of data:
  PING: transmit failed. General failure.
  PING: transmit failed. General failure.
  PING: transmit failed. General failure.
  PING: transmit failed. General failure.

When I run the same command from an instance of cmd.exe started "As Administrator" ping works as expected.

I have searched over the group policy settings and through the entire registry and cannot find what might be causing this.

Here is what I have tried so far (rebooting after each change in setup):

  • Verified that the windows firewall is off
  • Verified that there is no AV running (not even installed)
  • Verified that Microsoft Security Essentials is off

Tried all of the following command line commands:

  • netsh int ipv4 reset reset.log
  • netsh int ip reset resetlog.log
  • netsh winsock reset catalog
  • ipconfig /renew
  • ipconfig /flushdns

I Have verified/toggled the following registry key values:

  • HKLM\System\CurrentControlSet\services\Tcpip\Parameters\EnableICMPRequest = 1
  • HKLM\System\CurrentControlSet\services\Tcpip\Parameters\EnableICMPRediredt = 1
  • HKLM\System\CurrentControlSet\Control\Lsa\restrictanonymous = 0 (tried 1 too)

I have verified/toggled the following group policy values:

  • Computer Configuration\Windows Settings\Security Settings\Local Policies\ User Rights Assignment\Access this computer from the network: Added non-admin users

I also did tried the following steps without success:

  • Reboot into safe mode
  • Create a new standard user and try from that account
  • Unplug all network cables and disable all network adapters
    • Ping from admin works for 127.0.0.1, standard user gets same error.
  • Turn PXE off for the NIC in the BIOS

I am at my whits end on this one and could really use some help!

** Edited to add more things I've tried.

Edit 2, add some retyped output from route print

Interface List (shows 4 adapters and 1 Software Loopback Interface)
IPv4 Route Table
Network Destination   Netmask           Gateway   Interface    Metric
... other lines here ...
127.0.0.0             255.255.255.0     On-Link    127.0.0.1   306
127.0.0.1             255.255.255.255   On-Link    127.0.0.1   306
127.255.255.255       255.255.255.255   On-Link    127.0.0.1   306
... more lines here ...

Link back to original Stack Overflow question

  • just to be clear, you get this for all destinations, not just loopback addresses, right? – Frank Thomas Sep 19 '17 at 16:29
  • Yes, I get this for all destinations. Loopback was given as the simplest case to describe the problem. – Ben Sep 19 '17 at 17:05
  • Note that I can access network assets as a standard user. For example I can access a server file share at \\192.168.x.y\ShareName even though I cannot ping 192.168.x.y – Ben Sep 19 '17 at 17:06
  • Is your machine logged in a domain? – Alex Sep 19 '17 at 19:18
  • No, not on a domain. – Ben Sep 20 '17 at 1:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.