1

I have Windows 7 Pro, SP1, and I am logged in as "Mark", which is an admin account. I can check that in the Control Panel "Users" app, that indeed I am admin.

My successful Visual Studio compilation of some extension, created some folders, such as "obj", which are subsequently impossible to remove.

I tried doing it from: cmd running as Admin, Cygwin, Safe Mode, all failed.

I checked permissions permissions say this account has full access.

In any case, I am also unable to change permissions, and unable to change ownership.

The ownership will not display, it says "unable to display ownership".

The folder in question is "Read-only" in Properties, and I am also unable to uncheck that box and OK.

Same thing holds true for any of the individual files in the folder.

The Administrator account is enabled, the above problems happen whether I log in that account, or my account with Admin privileges.

All these actions result in some variation of "permission denied", "need to be admin", "need to acquire ownership" and such.

I Googled and all of the solutions I found on various fora, including MS, involve some variation of some of the above, and I tried all of them, and noone work.

What else to do?

9
  • First make sure Administrator account is enabled by going to computer management-->Local Users and Groups-->Users-->, right-clicking administrator and going to properties. You should set administrator password. Then log into that account by switching users and logging in as administrator. Sep 19, 2017 at 23:13
  • @SergioDominguez Did not work. I have enabled the Admin account and logged in to it, but when I try to delete the files, it still says that these files are owned by "Mark" and I need permission from that account.
    – user322908
    Sep 19, 2017 at 23:26
  • 1
    I have found this solution online, not sure if it will work but work a try. The issue is with UAC. You can disable the UAC feature that triggers this. Start---run---gpedit.msc Computer Configuration -- windows settings --Security Settings -- Local Policies -- Security Options Scroll down to: User Account Control: Run all administrators in Admin Approval Mode - Set to DISABLED. Reboot. Done. Sep 19, 2017 at 23:29
  • 1
    The accepted solution might work but it's completely disabling UAC,which is a bad idea. stackoverflow.com/questions/1088593/… should be a better solution.
    – HoD
    Sep 20, 2017 at 14:08
  • 1
    @svin83 Yes I just disabled the feature for a moment, in order to delete the offending stuff, then I enabled the protections back again. Thank you for the warning.
    – user322908
    Oct 21, 2018 at 20:45

1 Answer 1

2

You can disable the UAC feature that triggers this. Start---run---gpedit.msc Computer Configuration -- windows settings --Security Settings -- Local Policies -- Security Options Scroll down to: User Account Control: Run all administrators in Admin Approval Mode - Set to DISABLED. Reboot. Done.

1
  • 1
    but consider: this is a security feature, you should re-enable it after making the necessary changes! (see Question comments above)
    – eFloh
    Aug 30, 2019 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.