4

I have a Dell XPS 13 9350. It runs Windows 10. It is the latest insider preview, but this issue has appeared and disappeared, even on the stable builds.

When I put the computer to sleep, either by choosing 'sleep' from the shutdown option in Start, or by closing the lid, it turns off the screen, only for it to turn on again with airplane mode enabled. The computer remains active and does not go in low-power mode, leading to drained batteries.

I've already run powercfg -requests but nothing seems to keep the computer awayke. I have a dualboot setup with Ubuntu 16.04 which sleeps just fine, so it's definitely Windows. Any ideas as to what might cause this?

Edit: I also noticed that issuing the Sleep command a second time (after it turns on Airplane mode), will disable airplane mode. It's like Sleep means: log out and switch on airplane mode, instead of: sleep.

  • 1
    WEIRD- I had this same problem on a laptop long ago, but it was running Ubuntu, Linux! Same itermittancy, same exact issue, just a different OS... I wonder if this issue arises from how some low level OS function interacts with the hardware... never did solve it – Blaine Sep 20 '17 at 6:20
1

Consider it's related to power save settings on Wired or wireless network adapter. Please try to check on this option:

enter image description here

If this doesn't work, export the energy report by running this commands and post here:

powercfg /energy

I have noticed this error in your energy report, it seems that there is the USB mouse may cause your issue. Please unplug this mouse and see if your sleep can work fine.

USB Suspend:USB Device not Entering Selective Suspend

This device did not enter the USB Selective Suspend state. Processor power management may be prevented when this USB device is not in the Selective Suspend state. Note that this issue will not prevent the system from sleeping.

Device Name USB Composite Device

Host Controller ID PCI\VEN_8086&DEV_9D2F

Host Controller Location PCI bus 0, device 20, function 0

Device ID USB\VID_046D&PID_C52F (This is an usb mouse device)

Port Path 2

See these: please configure your sleep mode again, in advanced power option, enable USB settings:

enter image description here

Power Policy:Sleep timeout is disabled (Plugged In) The computer is not configured to automatically sleep after a period of inactivity. Power Policy:USB Selective Suspend is disabled (Plugged In) The current power policy has globally disabled USB selective suspend.

Weird issue.

Not sure if this is related to the insider preview version. Since such version of Windows are still in testing, some issue can be noticed when it was used, you can submit some feedback to see if there's any similar issue.

At this time, i would like to suggest you to update the BIOS and run commands below to repair system components:

Dism /Online /Cleanup-Image /RestoreHealth

SFC /scannow

  • Hi Kate Li, thanks for the answer. I tried the suggested setting but it doesn't change anything. The results from powercfg /energy are here: justpaste.it/1bgrt. – bluppfisk Sep 20 '17 at 7:53
  • Hi Kate, I found the device under Human Interface Devices. However, disabling or uninstalling the device, does not fix sleep. Any idea why? – bluppfisk Sep 21 '17 at 7:18
  • Hi Kate, that's what they're set to. I manually toggled the settings to make sure the right setting is saved, but no avail: when pressing the 'sleep' menu item, the computer goes dark for only a few seconds and then shows the screen again. – bluppfisk Sep 21 '17 at 8:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.