I'm running Mac OS Leopard and using a Targus Bluetooth Laser Mouse and just recently, on two different computers, the mouse buttons stop being able to control Spaces. They work fine for activating Exposé but Spaces will not respond to any mouse buttons. Keyboard and hotspot activations work fine.

For over a year it has been working fine. Just made a clean install of OS X and still have the problem. Restarting fixes it, but it invariably returns if I use the computer for a while. Seems to happen after activating Spaces.

Also, I'm not using the Targus software to configure this. I don't have that installed and am just using the Expose & Spaces system preference pane to do this.

Just got a brand new 2010 15" MacBook Pro with Snow Leopard and it was working great until this morning and it suddenly stopped working. I've rebooted, which always fixed the problem under Leopard, but isn't doing it for Snow Leopard.

  • Does Spaces still continue to work in general (i.e. you can activate it from the keyboard)? – dtlussier Sep 10 '10 at 17:49
  • Yeah, no other problems. Works fine when activated via keyboard or hotspot. It's just the mouse button. – donut Sep 10 '10 at 19:52
  • LOL! I was going to ask, why would you need to assign Spacebar to a mouse button, later I've realized that Spaces is probably a program or so. – nyuszika7h Jan 22 '11 at 14:04

The thread MX Revolution Mouse Problem with Snow Leopard offers this workaround for mouse problems. Might be worth trying:

ln -s /Applications/Utilities/Expose.app /Applications/Expose.app
ln -s /Applications/Utilities/Spaces.app /Applications/Spaces.app
| improve this answer | |
  • Doing this hasn't made a difference. But it did give me the idea to install the Targus software of have it point at Spaces for that button. – donut Sep 11 '10 at 17:18

This should fix the problem, let me know how successful it is:

  1. Delete homedirectory/library/preferences/com.apple.dock.plist
  2. Logout and login again
  3. Spaces may be turned off; turn it back on, and set the mouse shortcut to what you want to use.
| improve this answer | |
  • I just tried it and it didn't make a difference. Still having the problem. Thanks anyways! – donut Sep 14 '10 at 17:10

A working solution for this is to remove the preferences file that stores the hotkeys and mouse configuration. Note that it is not the com.apple.dock.plist file as noted in another answer. Also note that once you have deleted the aforementioned file, all your hitherto hotkeys and mouse related configuration is reset to their defaults.

Open up a terminal and type:

# rm -f ~/Library/Preferences/com.apple.symbolichotkeys.plist

Once you're done with that, log out and then log in again. Go to the System Preferences and reconfigure your Expose and Spaces settings. Now everything will work fine.

| improve this answer | |

I've consistently had the same issue where I boot up my iMac (10.6.5) and every other time my Mouse button 4 won't activate Spaces. Restarting would usually fix it. Yet, even going into System Preferences -> Mouse and changing Spaces to the right-click (for example) doesn't effectively update. The right-click continues to do what it was previously set to. The answer that just worked for me was to expand the options for Mouse Button 4, choose "Other" and navigate to Applications -> Utilities and choose Spaces.app. Once I did that and used Mouse Button 4, spaces worked as normal. I don't believe the issue is with the actual Spaces.app because my keyboard shortcut could still activate it. My goal was to resolve this without having to restart because at work, where this issue occurs, I cannot restart my computer once I'm logged in.

Hope this helps.

| improve this answer | |
  • 1
    That's what I ended up doing, as well. But then sometimes there is sometimes a delay before Spaces is activated. Now I've got USB Overdrive and have assigned the F8 key to the appropriate mouse button and it's working much better. I'm think it's a problem with Spaces since I can still assign mouse buttons to Exposé. – donut Feb 9 '11 at 17:48

Never found a solution to this. Ended up installing the Targus management software from their website and set the buttons to open Spaces.app instead of using the OS X mouse system preferences which were working for a while now. Not ideal but it works. Using the mouse with an iMac at work and it seems to be working just fine so far. Not sure why it's given me troubles with my laptops.

Update: I have moved to using USB Overdrive and assign the F8 key to the desired button. This is functioning better (no delay) than using the Targus software and assigning the Spaces.app to the button.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.