3

By company policy I must access Citrix via the web client to get to my work desktop. When I elect to go fullscreen, when I press ESC, the window pops back into the browser.

That would be fine if that's what I wanted. What I want is for ESC to be sent to the application I'm working in with my desktop.

I looked around and found that launch.ica (the file that starts the remote session) can be customized, but didn't see anything related to this.

3
  • I am pretty sure Citrix requires the use of a modifier key to pass a key command like the escape key (especially if its existing full screen mode) have you tried to use the Citrix modifer key?
    – Ramhound
    Sep 20 '17 at 21:54
  • 1
    This is standard browser behavior. ESC will absolutely and always exit full screen mode. It’s a hard-wired default so you cannot be locked in your browser.
    – Daniel B
    Sep 20 '17 at 22:10
  • @DanielB, Shoot. It was the "man" in the middle. I forgot that.
    – Kit
    Sep 20 '17 at 22:41
3

Don't use the Citrix option to make the window fullscreen. Use the browsers option for fullscreen by clicking it in main menu. E.g. in Chrome: Chrome fullscreen option in main menu

1
  • Much easier solution. This works on chrome (F11 for full-screen).
    – jaamor
    Jul 12 '19 at 18:49
1

As DanielB pointed out: it's not Citrix that did the hijacking. It's that the browsers' escape from fullscreen via ESC is in play, and has no awareness of Citrix being run.

Maybe there are some contortions to bypass this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.