1

I asked this on Reddit: https://www.reddit.com/r/techsupport/comments/718dw8/cant_disable_dynamic_contrast_ratio_or_auto/

So I got my new gaming PC a couple of days ago for Battlefield 1 and PUBG, everything else works fine but there seems to be some kind of dynamic contrast ratio or auto brightness I can't disable, basically the contrast ratio or brightness of the screen changes slowly (10 - 20 Hz) depending on the color or grey scale of the content on the screen, and I suspect this is the cause for the frame rate drop when I play games (with 1440p and ultra graphics settings in both games the fps is around 60-70), both GPU and CPU temperatures are normal (60 degrees Celsius for GPU and 40 degrees Celsius for CPU), I have tried everything I can find on Google but I just can't disable this feature. Please share any thoughts you guys have, thanks!

Similar issues I found online: Can't put them here but in the reddit post there are links to a couple of similar issues.

Spec:

  • Operating System: Windows 10 Home 64-bit version 1703
  • PSU: EVGA - SuperNOVA NEX 650W
  • GPU: STRIX-GTX1080TI-O11G-GAMING
  • CPU: Intel - Core i7-7800X
  • RAM: Corsair - Vengeance LPX 16GB (2 x 8GB) DDR4-3000 Memory
  • Motherboard: Gigabyte - X299 AORUS Gaming 3 ATX LGA2066 Motherboard
  • GPU Driver: Nvidia 385.41 WHQL
  • Monitor: Dell S2716DG with G-Sync

Speccy Link:

http://speccy.piriform.com/results/y5hBtApdrwPGh4yxUgzaqDG

Cause/Steps to recreate the issue:

Turn on the PC, whenever the color or brightness of the contents on the screen is changing the contrast or brightness of the screen changes slowly.

What I've tried so far to resolve the issue:

  1. Turn off Adaptive screen brightness in Windows power plan (nothing changed)
  2. Turn off Dynamic Color Enhancement in Nvidia control panel: there is no such option in the "Adjust Video Color Settings" tab, when choosing "With the NVIDIA setttings", you can only choose from Limited (16-235) or Full (0-235) dynamic range. (not solving the problem)
  3. Choose Prefer max performance as power management mode in Nvidia control panel and set refresh rate as 144Hz in the Display -> change resolution tab. (nothing changed)
  4. I don't have an Intel graphics card (not for me) Stop Sensor Monitoring Service (nothing changed)
  5. Uninstall Nvidia driver completely (using Display Driver Uninstaller) and reinstall the latest Nvidia driver (nothing changed)
  6. There is no such option in the monitor menu and switching to another monitor I have didn't solve the problem so I'm pretty sure it's not related to the monitor.
  7. I don't have Power4Gear on my computer.
  8. The next thing I'm gonna try is reassemble the PC, reinstall the OS and drivers and prey.
  • It it's changing at 10-20 Hz (as Hertz is 1*(1/s)) it would change within 100ms - 50ms which would be rather quick and likely would be constant flicker? What other software do you have running while gaming? – Seth Sep 21 '17 at 5:32
  • I'm not completely sure what the frequency is, but when it happens the in game fps drops significantly, I'm not running any other software while gaming. Could it be related to BIOS? Or graphics card? – SMGRushBNoStop Sep 21 '17 at 6:00
0

You can fix this as follows:

  1. Click on Start and type 'services'
  2. Right-click and choose 'Run as administrator'
  3. Click on 'Intel(R) HD Graphics Control Panel Service' from the list.
  4. In the General tab click on 'Startup type', select 'Disabled'
  5. Click OK, and restart the computer.

You might have to do this again if the windows updates your Intel graphics driver.

  • Thanks for the answer! But as I said in the 4th approach I tried, I don't have an Intel Graphics card, and there is no such option. Eventually I bought another monitor and it's working fine now. : ) – SMGRushBNoStop Nov 17 '17 at 2:00
0

The implementation of dynamic contrast ratio (often implemented in conjunction with changes in screen backlight levels) is specific to video driver software.

ATI / AMD video drivers

Dynamic contrast (Vari-Bright™) can be disabled in the AMD Catalyst Control Center under "PowerPlay™" by clicking on the yellow areas as shown in the screenshot below: AMD Catalyst Control Center PowerPlay™ Options

0

I usually don't post on these questions, but I have been INFURIATED by this problem for so long and I finally figured out the solution, and I feel a moral obligation to post it. Like OP, I tried changing adaptive brightness in the power plan, I tried fiddling with NVIDIA control settings, intel settings, etc. Nothing worked. But then I found the solution!

The problem isn't your laptop manufacturer, it isn't intel, it isn't NVIDIA. It is windows 8 & 10. It is called Windows "Sensor Monitoring Service".

Here is an explanation about it: http://batcmd.com/windows/10/services/sensrsvc/

So I'm not a computer guru and am I sure there is a better way to do this, but after reading that link (which talks about restoring the feature) I deduced that the file responsible was safe to delete. So I deleted the file and problem solves! The auto-dimming or whatever problem went away, with no discernible issues, and I couldn't be happier.

Just go to the windows/system32 folder, look for the file "sensrsvc.dll", and delete it. Empty recycle bin/run CCleaner, restart, problem solve!

Again, there problem does exist a way to disable it without deleting it, but I'm not savvy enough to figure it out on my own.

Hope this helps!

PS - if you see this and are helped by it spread the word, I cant tell you how many of these message boards I saw the same question asked on with no solution posted

0

what worked for me was to disable "Diplay power saving technology" from Intel HD Graphics control panel. you can access it from Power settings of the Intel HD Graphics control panel.

  • 1
    OP has a discrete GPU and does not mention Intel HD Graphics. Can you point to a similar setting on the STRIX-GTX1080TI-O11G-GAMING? – Dave M Dec 26 '18 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.