I have already set up multiple time File History without problem but this time everything seems fine but when the "backup" is done, FileHistory\xx\xx\Data\C\Users\xx is empty.

In Event Viewer, under Application and Services Logs, Microsoft,Windows, FileHistory-Engine, FileHistory backup log, I have many errors like this "File was not backed up due to its full path exceeding MAX_PATH limit or containing unsupported characters". This somehow prevent the backup.

I have removed the files with a too long path and File History is now working as expected.

I thought that the files with a too long path were backup in xx\xx\Data\$OF. So why did my files prevented File History from working?


First of all, long path name file will be backed up in $OF folder with renamed name instead of its original name.

According to Microsoft official document:

Starting in Windows 10, version 1607, MAX_PATH limitations have been removed from common Win32 file and directory functions. However, you must opt-in to the new behavior.

A registry key allows you to enable or disable the new long path behavior.

To enable long path behavior set the registry key at HKLM\SYSTEM\CurrentControlSet\Control\FileSystem LongPathsEnabled (Type: REG_DWORD).

The key's value will be cached by the system (per process) after the first call to an affected Win32 file or directory function (list follows). The registry key will not be reloaded during the lifetime of the process. In order for all apps on the system to recognize the value of the key, a reboot might be required because some processes may have started before the key was set.

The registry key can also be controlled via Group Policy at

Computer Configuration > Administrative Templates > System > Filesystem > Enable win32 long paths.

| improve this answer | |
  • Does File History actually work with long paths after that change? Interestingly the Backup and Restore (Windows 7) component works with long path names without problems by default, no need for configuration changes. – David Balažic May 28 '19 at 18:51
  • I tested it. I set the registry key, restarted Windows and started a backup that contains a long path name (and it failed before). Then I restored it. Result: there is no more error in Event Log, but in the restored files the long path file is still missing. EDIT: The reason was that the file was not changed, so it did not even try to back it up again. I set up another test folder and there the same error was reported as before. So LongPathsEnabled does not help at all. FYI: I have Windows 10 Home ver 1809 64 bit – David Balažic May 28 '19 at 19:54

If you find file history is empty, try checking again under FileHistory***\OneDrive\ If your files are synced they will be backed up under the OneDrive and the path that does not include OneDrive will be empty.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.