19

I have this issue where windows randomly adds keyboard layouts for me. This is beyond annoyance and I'm starting to feel suicidal. (Okay maybe it's not that bad but it's still pretty annoying.)

s1

I want to have two keyboards:

  • ENG (United States)

  • CS (Czech QWERTY)

The other two were automatically added by windows (ENG CSQ and ENG UK) but they don't show up in my language list.

s2

The only way to remove them, is to add them manually in the language list, exactly as they are in the keyboard layouts window. Then delete them. I did this several times but the two random keyboards keep coming back. How do I stop windows from adding these automatically?

1
  • Have you figured this out yet? I'm in the same position yet none of the answers worked ! – Nour Feb 27 at 18:43
2

Try this. At least it's work for me.

https://it42.cc/2018/11/04/windows-10-unwanted-keyboard-layout-fixed/

In order to fix this problem you have to do following steps:

Go to setting > Time & Language > Region & Language > Administrative language setting Under Welcome screen and new user accounts make sure that there are no extra keyboard layout appear in the list Click OK and Restart PC. This should fix your problem.

1
  • 1
    Welcome to Super User! Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Nov 4 '18 at 10:12
1

I find that some people have the same issue and gave some answers in the link below.

keyboard layout (United Kingdom) is automatically added

You could reinstall the language package to see if the issue can be fixed. https://www.tenforums.com/tutorials/3813-language-add-remove-change-windows-10-a.html

I might suggest for Reset option with keeping your files.

Not the answer you're looking for? Browse other questions tagged or ask your own question.