2

I have an SNMP issue with the community name.

The default name is "public". When I tried to change it to anther one, I find that I can walk the SNMP with two name "public" and "loreal" (giving the command snmpwalk) without apparent errors, like in lines below :

C:\>snmpwalk -v1 -c LOREAL 128.86.201.207 enterprises.683.3.3.0
SNMPv2-SMI::enterprises.683.3.3.0 = STRING: "LOREAL"

C:\>snmpwalk -v1 -c public 128.86.201.207 enterprises.683.3.3.0
SNMPv2-SMI::enterprises.683.3.3.0 = STRING: "LOREAL"

But when I use the command snmpSET, I can't use the new name ("LOREAL") to change value

C:\>snmpset -v1 -c LOREAL 128.86.201.207 enterprises.683.3.3.0 s SWAT
Timeout: No Response from 128.86.201.207

C:\>snmpset -v1 -c public 128.86.201.207 enterprises.683.3.3.0 s SWAT
SNMPv2-SMI::enterprises.683.3.3.0 = STRING: "SWAT"

Why this happens, how can I definitively change or delete the "public" and use only "LOREAL" for the snmpset/get commands?

Notes:

  • Add the version of the OS and of the SNMP. You can always edit your own post. What do you mean "I figer that I can walk"? – Hastur Sep 25 '17 at 13:52
  • Check if the edit make it more clear and edit it again adding the operations you have done to set/change the new name, making more clear the Note... good luck. – Hastur Sep 25 '17 at 14:02
  • I always have the same problem with language i need improve my English before posting here, thanks – yazan Sep 25 '17 at 14:08
  • Add some tags as the windows version for the OS... some one may filter the question through the tags. BTW the bigger part of the users here has to translate in English question and answers. :-) Try. Continue to try. Use wordreference, collins google or whatever... and good luck. – Hastur Sep 25 '17 at 14:14
  • You are welcome. Add your OS version... NOW ! :-) If it was Linux you should had found interesting the page "How to change the default value for the SNMP community string ". They suggested to change the value by hands in the snmpd.conf file and restarting the daemon... So you can start to see the configuration file under your OS. Here for windows. – Hastur Sep 25 '17 at 14:23
1

I found solution, my problem was with the version firmware for this printers.

the model of printers is ZT230-200dpi ZPL and the version of firmware was V72.19.1Z, so when I try to change community Name with zpl commands , the commands were execute incorrectly.

I did upgrade the firmware to V72.20.1Z and I tried to send zpl commands, now I have response from SNMP get/set and I can change the values with the chosen community Name

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.