2

As part of a common workflow, I might write a sentence like "group makes announcement."
I then double-click on the word "announcement" to select that word, CTRL+K to bring up Insert Hyperlink, CTRL+V to paste a URL I've previously copied from a browser while open to the announcement page, and Enter to close the Insert Hyperlink box.
In quick succession I might switch back to the browser, copy the URL of the group's homepage (or any other URL that's a subset of the start of the previous URL). I return to the document, double-click on "group," CTRL+V and Enter.
However, after CTRL+V, Word autocompletes the longer previous URL, so when I quickly press Enter, it incorrectly saves the longer URL as the destination of the link. Because I do paste and enter so quickly, and because there may be a slight delay in the autocomplete so it might not appear until a tiny fraction of a second before the dialog closes, I often don't notice this until much much later.
Also, it happens even when the longer link was not recently pasted, and I might have forgotten that at some time in the past I pasted a link to some URL further down a site's hierarchy than the link I'm pasting now.

On Microsoft Answers, you can find the example that

http://test.link.nl/page=1

would actually get autocompleted to a previously linked to page,

http://test.link.nl/page=12

This is very undesirable behavior and I'd like to disable it.

Microsoft's answer was to provide steps on how to delete the autocomplete history through Internet Properties (which seems to assume Internet Explorer as a user's primary and sole browser), but a solution requiring that procedure after every link being pasted is not acceptably usable in addressing the problem, and doesn't even solve it.

Answers for any version of Word can be helpful, with a bias toward newer ones.

2

Too bad to tell you that many of Word's running functions and their dialogue boxes were developed over 10 years ago. At that time, based on my personal experience, Word relied for inserting links on Windows Explorer, which was designed to be (or was behaving like) a web browser and a file explorer. That's why the Microsoft's answer came like you read it, and not that Microsoft assumes people use Internet Explorer as their sole browser while it got superseded by Edge, which in return broke, as I guess, many functions due to lack of development. The answer Microsoft said there would work, only if you went back over 10 years.

So you got nothing but to get used to press space after pasting. Spaces won't be considered as parts of the link and thus adding them is a safe habit; it will erase the selected part of the link if the link was auto-completed, or will have no effect if you pasted a new link. Cheer up :)

  • @WBT You're welcome! If this post solved your problem, mark it as the answer to let other people know. – Sanny Oct 4 '17 at 13:49
  • It's not a complete solution, because it still requires user-specific action each time a link is inserted instead of actually disabling the autocomplete. However, it's definitely worth an upvote, which I've given! – WBT Oct 4 '17 at 20:00
  • @WBT Agreed. One more up vote. Oh how I wish MS products would stop trying to guess what I want. – ScottWelker Apr 22 at 19:14
0

I am also annoyed by this behavior! I found this reply to your post on answers.microsoft.com that suggests clearing history from Internet Explorer to remove any suggestions from the autocomplete list.

"Show AutoComplete suggestions" (at File | Options | Advanced) does not apply to the Hyperlink dialog box; the option displays suggestions for Building Block entries and dates.

Here, clearing the history for Internet Explorer does clear the suggestions in the Hyperlink dialog box (even though I don't have IE set as the default browser on this computer).

Stefan Blom Microsoft Word MVP Volunteer Moderator (MVP program information: https://mvp.microsoft.com/)

This worked for me and when I repeated my test case (that caused me to Google and find this SuperUser post) I did not get the annoying autocomplete.

  • 1
    That link is already in the question, along with an explanation of why it is not a satisfactory answer to the question. – WBT Dec 17 '18 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.