0

I recently have had several issues of BSOD all of a sudden on my PC. After a clean install of OS , it seemed to disappear for some time. When I tried to update the firmware on the SSD where the OS sits, the firmware update manager from Crucial says the SSD is not configured in AHCI but in IDE mode, I run a AsRock UEFI setup, and searched everywhere to see what is the current configuration. But couldn't find one.

If anyone has any idea how to enable AHCI mode for SSD in AsRock UEFI bios ?

  • Does this look familiar? tenforums.com/attachments/tutorials/… – user772515 Sep 22 '17 at 19:56
  • @MichaelBay My bios settings shows its already in AHCI mode, however when I try to update my SSD firware from Crucial SSD software, it shows this – Rene Duchamp Sep 24 '17 at 22:22
  • "Dual Channel PCIE IDE Controller" most definitively isn't AHCI. – mirh Jan 7 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.