1

I am unable to remove a very deep directory tree. When I try to delete it normally, it just stays at 0% and nothing happens.

I have tried using the robocopy method with /purge, which ran for over 1 hour with nothing happening.

I then tried the Deep Remove tool from here: https://github.com/juanpablojofre/deepremove

It says it detected 1520 folders and then I get this error message:

Deep Remove error message

I have successfully used the deep remove software before, but it doesn't work in this case. I think it might be because the subdirectories don't have the same name, but are somehow named better-ticket-machine and better-ticket-machin every other folder. Does anyone have any idea about how to fix this?

  • 1
    Looks like a folder has a subfolder hardlinked to its parent, though that shouldn't be possible. Does a chkdsk help? – Ben N Sep 23 '17 at 18:00
  • If it's legit structure you could dive deep into the structure and then be sure the folder you are in that the remaining characters are less than 255, create a share at that folder level as share1$ and then after that close all instances of any explorer you have opened with any of these folders, etc. Now connect to the \\localhost\share1$ and the very first folder delete it, etc. you then undo the share and repeat the same process again leaving under 255 chars in the full path.Otherwise, consider booting to Linux disk or something and try to remove. – Pimp Juice IT Sep 23 '17 at 18:02
0

You can use this tool to scan the directory tree to find path names longer than 255 characters:

https://sourceforge.net/projects/tlpd/files/v4.6/source/

and then rename them.

TLPD was developed as a complementary product for the EVACopy project: http://evacopy.sourceforge.net

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.