2

In the past I have not had any issues with Windows Update. My system is Windows 7 Home x64 SP1.

A couple of weeks ago the monthly rollup update came out "September 12, 2017—KB4038777 (Monthly Rollup)". The update failed as follows:

I have Windows Update set to download important updates, but wait until I install them. The update was successfully downloaded.
Opened Windows Update and installed the update. Finished "Successful". Clicked on "Restart". Update got to 30% (as usual) and computer restarted. After restart, system loading looked OK, and the update proceeded to around 70%.
Then it displayed "Failure configuring Windows updates - Reverting changes".

enter image description here
After that and another restart, the systems booted OK and Windows Update history showed the update "Failed".

I had tried the update several times since then with the same results (error codes 80073AA2 and 80070570.

I tried the standalone updater for KB4038777, but it failed in the same manner.
Then I tried the standalone updater for KB4038779 (Security-only update), and this update was successful.

I would like to understand better how to troubleshoot these kinds of problems though.

When a monthly rollup update fails, is there any way to know which specific update caused it? And does the "revert" step remove all the updates, or just the failed ones?

And what log file(s) contain such information? I found "WindowsUpdate.log" but there did not seem to be any judgmental information, just activity information.

UPDATE November

Same occurrence for the October and November monthly rollup updates (failed), but the Security only updates were successful.

For November, the Windows Update error:

enter image description here

This time I localized the error in the cbs.log file.
You can see it in this file: cbs error log if you search for "80073aa2".
Seems to be related to WmiCmiPlugin, but I have no idea beyond that.

Is further troubleshooting possible?

  • 1
    Can you update question with exact messages/errors? “Could the download be corrupted?“ - Download the update from the catalog and attempt to install it and update your question – Ramhound Sep 24 '17 at 23:03
  • Can't believe that I didn't think of that, since I already got KB4038779 from the catalog. I'll try it. This wasn't high on my list since I assume the update confirms the integrity of the download. Also I am adding one more question. – user3169 Sep 25 '17 at 1:45
  • I would reduce the number of questions you asked not increase them – Ramhound Sep 25 '17 at 2:22
  • “When a monthly rollup update fails, is there any way to know which specific update caused it?” check the log of course – Ramhound Sep 25 '17 at 2:23
  • I asked because it may be a related issue. Anyway I checked the update log and don't see any error. As I said, the update (in Windows Update dialog box) ends in success. Only after restart and loading the system updates (prior to the login screen) does the "revert" message appear. I could attach a portion of the log file, but I don't know how to attach text files. – user3169 Sep 25 '17 at 3:27
3

The error code 0x80073aa2 means ERROR_EVT_CONFIGURATION_ERROR. So there is an configuration issue regarding Windows Events.

Looking in your CBS.log shows that the configuration for Microsoft-Windows-RPCSS is damaged:

2017-11-16 10:07:19, Error CSI 00000002 (F) Logged @2017/11/16:18:07:19.635 : [ml:284{142},l:282{141}]"EventAITrace:Provider Microsoft-Windows-RPCSS{{d8975f88-7ddb-4ed0-91bf-3adf48c48e0c}} is missing the channel name for the index key (null).

2017-11-16 10:07:19, Error CSI 00000003 (F) Logged @2017/11/16:18:07:19.698 : [ml:170{85},l:168{84}]"WmiCmiPlugin wevtcfg.cpp(2271): InstrumentationManifestAssert failed. HR=0x80073aa2."

To fix this, run regedit.exe, go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion‌​\WINEVT\Publishers\, press CTRL+F and search for Microsoft-Windows-RPCSS. Now you see the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion‌​\WINEVT\Publishers\{‌​d8975f88-7ddb-4ed0-9‌​1bf-3adf48c48e0c} where the Microsoft-Windows-RPCSS events are stored.

enter image description here

So delete the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion‌​\WINEVT\Publishers\{‌​d8975f88-7ddb-4ed0-9‌​1bf-3adf48c48e0c} and now Windows Update should install fine.

|improve this answer|||||
-1

SOLUTION! THIS WORKED FOR ME!

Check the free space on your 'System Reserved Drive' (Drive Z: in my case). Mine was 99% full, so I increased the partition size from 50MB to 100MB using Minitool Partition Wizard (free).

I asumed the 'monthly quality rollup' updates might be trying to write to this drive during boot sequence, but because there was no space left it failed and done a roll-back. Since doing this, all my Windows Updates have worked fine now for past 3 months!

I had the same issue as many others report (on Windows 7) and for 6-8 months I read all these posts with no solution in sight.

Hope this helps somebody :)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.