1

I stumbled upon weird Windows 8.1 and Windows 10 dual boot. Both 8.1 and 10 are on a separate disks (not partitions, although I recon the same would apply for partitions).

The problem is that W10 and W8.1 "file structure" seems to be incompatible. When booting to W8.1 it finds W10 disk/partition and thinks W10 disk is somehow corrupted. Check and repair takes forever (1+ hour) and when booting to W10 it tries to repair its files back... Of course W10 thinks W8.1 disk is corrupted. For every startup one has to be prepared to "Press any key to skip disk checking".

And even after boot, if the disk was not repaired, it has 100% disk activity all the time. Which drops the performance to "not usable at all".

Would this dual boot somehow be possible?

"Windows on the go" has a feature where only the disk operating system is booting from is mounted. Rest of the discs are disconnected as a security measure (we don't want any nasty viruses, or accidentally saving a precious file on someone else's hard drive).

Is there any way to tell windows not to mount disks on startup (ideally not even check them during boot)? Somehow set up a default to use a single disc (not necessarily a single partition) until other disks are manually "mounted"?

Or in other terms: Even if my computer has physically connected 10 hard drives, I would like to make windows use only One. Other 9 drives would be totally ignored until I manually mount them. Kind of software equivalent of having them physically disconnected and reconnecting them only when needed.

  • The best I can think of is write a script to unmount the volumes automatically. This could be done before the user even has the ability to view the contents of the drives in theory. – Ramhound Sep 25 '17 at 20:07
  • @Ramhound: a friend of mine connacted me with an issue that fits this problem better then my original setup. Therefore I changed the "backstory" entirely. While unmounting automatically would resolve the 100% disk activity, one would still need to skip disk checking... – Viliam Aboši Sep 26 '17 at 10:02
-1

Maybe removing drive letters would be enough. Run Disk Management (diskmgmt) as Adminstrator, right click partition, select Change Letter, Remove. How to Hide or Dismount a Partition in Windows.

Alternatively disable automount by typing in elevated command prompt:

mountvol /N

To enable:

mountvol /E

  • I changed the "backstory" of my problem to better show what I need. Your solution solves the 100% disk activity. Unfortunately "skip disk checking" is still present... – Viliam Aboši Sep 26 '17 at 10:49
  • I kind of missed the "turn off automount" part of the answer. I tried it and it did the job. – Viliam Aboši Oct 9 '17 at 6:35

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.