0

I am aware that many people have this problem, but none of them seem to have the same details as me. I am attempting to create a live USB with persistance for Kali Linux (32-bit). I have followed the necessary steps:

  1. Installed the ISO file from kali.org
  2. Verified the sha256sum of the ISO file
  3. Used GParted to format my drive to FAT32
  4. Used GParted to create a persistence (ext4) partition
  5. Used sudo dd if=/home/arctic_hen7/Downloads/kali-linux-2017.2-i386.iso of=/dev/sdb1 bs=4M to extract the contents of the ISO file to my USB

This is when I noticed that after I went back into GParted to close it, the filesystem of the Kali Live partition (not the persistance) had become unknown (and a red exclamation mark sign appeared next to the partition name). Also, when I went into the persistence partition from Nautilus, it had a lost+found directory. I tried booting it like this (after adjusting my BIOS settings), but I was presented with a black screen and a flashing white underscore cursor in the top-left corner of the screen. I waited, but it did not boot. I then booted back into Ubuntu and tried the whole process again (but with the same ISO file), but I also deleted the lost+found directory in the persistance partition. I tried booting but was met with the same issue. My system specifications:

Ubuntu 16.04 LTS (alongside Windows Vista (which I never use))
Vaio VGN-Z46GD (quite old)
Intel Centrino 2
Insyde H2O BIOS

I hope this helps.

Edit: I have managed to fix the problem and now have Kali Linux 32-bit with persistence on a 32GB USB flash drive. Please see my answer below for the details.

0

Ok, I am not sure what the original error was (it may have been to do with remounting..), but I installed a program called UNetBootIn and followed the instructions on their website (https://unetbootin.github.io/linux_download.html) to download the program through the terminal. I then used it to extract the Kali ISO file onto my USB (not using their persistence option), and after checking GParted, found that the filesystem was still FAT32. I then resized the partition and created an ext4 partition with the 'persistence' label (to use for persistence). I then saved my changes, mounted the USB drive by ejecting it and putting it back in again, and then booted to it. I then followed the instruction on the website I was following (https://null-byte.wonderhowto.com/how-to/install-kali-live-usb-drive-with-persistence-optional-0162253/) and I then had persistence working. I hope this helps all those who have had a similar problem to myself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.