0

I connect to a distant machine to copy some arabic text to my machine.

When connecting through teamviewer, I get the text nice and clean when pasted on my machine, like this :

تدخر جهدا في سبيك توفير اكحماية ككصحفيين, وذكك بعد أن هددت حركة طاكبان اكمتمردة بشن هجوم عكى مقر قناتين تكفزيونيتين في كابوك واسته

When connecting through RDP, I get this instead

ÑæãÇ 27 ÓÈÊãÈÑ 2017 (æÇÌ)- ÍÞÞ äÇÏí äÇÈæßí ÇßÅíØÇßí ÇäÊÕÇÑÇ åÇãÇ Úßì ÖíÝå ÝíäæÑÏ ÑæÊÑÏÇã ÇßåæßäÏí (3-1) Ýí ÇßßÞÇÁ ÇßÐí ÌãÚåãÇ ãÓÇÁ ÇãÓ ÇßËßÇËÇÁ Úßì ãßÚÈ (ÓÇä ÈÇæßæ) Ýí ÅØÇÑ ÇßÌæßÉ ÇßËÇäíÉ ãä ÇßãÌãæÚÉ ÇßÓÇÏÓÉ ßßÃÓ ÑÇÈØÉ ÃÈØÇß ÃæÑæÈÇ ßßÑÉ ÇßÞÏã

Any tip on how to troubleshoot this ?

I am copying text from a third party application on the remote server to notepad on the local machine.

  • 1
    RDP shares the host clipboard, and notepad uses the system default encoding. so it doesn't surprise me that this is happening. have you considered using a more encoding-aware editor like Notepad++ or SublimeText? – Frank Thomas Sep 27 '17 at 11:49
  • I pasted on microsoft office word with same effect. See : i.imgur.com/VZTXQdY.png. Besides, notepad displays the text correctly when copying from teamviewer as I said in the description. – ychaouche Sep 27 '17 at 12:18
  • I suggested N++ or Sublime because you can manually select the encoding type. – Frank Thomas Sep 27 '17 at 12:43
  • @FrankThomas, to be more specific this is a problem that is occuring to my users and they're used to microsoft word. Installing other editors isn't an option at this moment. – ychaouche Sep 27 '17 at 13:07
0

Before doing the copy on the remote machine I had to switch the keyboard layout (alt-shift), then procede to copying the text and pasting on my local machine with the correct encoding.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.