0

Currently I have a wireless router running the Tomato firmware behind a pfSense box that is directly connected to the modem. I connected the pfSense box to the LAN port on the wireless router and the clients connected on the other LAN ports have Internet connectivity. However, the wireless router itself is not able to reach the internet. I am trying to give the wireless router internet connectivity so that I can use the vpn client that is on the Tomato firmware.

Network Diagram:

Any help would be appreciated.

  • So you're trying top use the wireless router just as a switch and access point? Do you have it configured for that? (No WAN port or WAN port disconnected. No DHCP server. Configured to get its LAN IP by DHCP or statically configured with a proper IP address and default route. And so on.) – David Schwartz Sep 27 '17 at 20:25
0

You need to set an IP address, default gateway address (the address of your pfSense box), and DNS server address on the Tomato router in order for it to have Internet access when used in this configuration. You also want to make sure that the DHCP server is disabled on the Tomato router so the only IP addresses on the network are either statically assigned or coming from pfSense.

You are effectively turning off routing on the Tomato system and using it as an access point and switch only.

  • So I gave the wireless router an unique IP address on the same sublet as the pfSense box, defined the DNS server, and made sure the DHCP server is disabled on the wireless router. Still no luck... imgur.com/a/hJeBj – Joe2265 Sep 27 '17 at 20:25
  • That image indicates you did so on the WAN side of the router though. You need to do all that on the LAN side of the router. There should be no configuration on the WAN side and you should have nothing plugged into the WAN port of the router. – Ben Franske Sep 27 '17 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.