0

I'm setting up a SFTP server by following the guideline here and it seems working fine, I can login to my SFTP user root directory by using sftp command:

    kongycmac:~ kongyc$ sftp kong@192.168.3.120
    kong@192.168.3.120's password: 
    Connected to 192.168.3.120.
    sftp> 

and I'm able to download all the files in the SFTP folder.

Unfortunately, when I tried to open my SFTP site in my browser, it seems like not working.

In my browser address bar I key in:

    sftp://192.168.3.120

and Chrome will redirect me to Google and search for the URL. I'm trying to setup a SFTP URL and whenever someone browse to the SFTP link, user can login with the password and download the files.

Is there any steps that I've missed out from the configuration?

  • Are you using FTPS, or SFTP? (I see you have tags for both ssh and ftp.) – jpaugh Sep 29 '17 at 3:59
  • @jpaugh Hi I'm using SFTP – Kyc Kyc Sep 29 '17 at 4:07
  • 1
    I would not expect Chrome to support the SSH protocol at all. However, you can use fuse to mount SFTP shares as network drives. If you're using Gnome, the Nautilus file manager has a menu option: File -> Connect to Server. It works with many network transfer protocols, including SFTP. – jpaugh Sep 29 '17 at 4:10
  • have you tried googling "chrome sftp plugin" ? – Archemar Sep 29 '17 at 6:05
0

Chrome does not support SFTP protocol.

Neither any other major web browser do.

What some browsers (like Firefox) can do, is to open the address in an external SFTP client, if the client registered to handle that protocol. For example WinSCP SFTP client does register to handle the SFTP protocol (I'm the author of WinSCP).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.