3

Disclaimer: I've read through numerous related questions and none of them seemed to fit this case.

I had two 120 GB SSDs installed. One running Linux (Debian), the other Windows 10. Trying to upgrade the windows SSD, I installed a new 250 GB SSD and copied the whole Windows SSD to the new one using dd. That worked and I can boot from it.

However the additional space of the new SSD is now unallocated space that I would like to merge with the primary C (sdb1) partition. Looking at it in a number of disk/partition managing applications, the picture is always such that the OS partition is on the far left, the new unallocated space on the far right. In between, there are two to three additional elements, the System Recovery partition (461 MB), 2 MB of unallocated space (not sure why) and a Linux swap partition of 8 GB. Roughly like this:

[C (111 GB)           ] [461 MB ] [2MB] [LS (8 GB)     ] [Unallocated (113 GB)  ]

Here is a screenshot from GParted for those who can load images:

Screenshot of GParted showing new 250 GB SSD

Here is one more that shows how Windows sees things:

enter image description here

Now, I've tried several tools, from Windows 10 disk management, to EaseUS Partition Master, AOMEI Partition Assistant to GParted. None of them are able to merge these partitions. Also, none of them are able to move either of these partitions.

How can I merge the C (sdb1) partition with the unallocated 113 GB?
I can use both, Windows and Linux tools.

2

First backup your important things from the Windows partition. Then I'd use the gparted from Linux. Backup the recovery partition (with dd) if you want to save it.

Unalocated space is fine, it makes no problem. If you are using the swap partition, stop it (swapoff) and remove it from /etc/fstab. Now in gparted delete the linux swap and backup partition. Now you can enlarge your windows partition to new size. The best leave some space for new linux swap in the end of the disk and eventually create new backup partition with the same size and using dd copy the original content there. Create new entry for swap in the /etc/fstab.

| improve this answer | |
  • Thank you, this did the trick. I thought the additional partitions were required, but after your answer I did some research and realized they are optional (in fact, I don't know how a Linux swap partition ended up on my Windows SSD). Hence, I deleted them with GParted, as you suggested, and was then able to merge the unallocated space into the primary (and now only) partition. Splendid! – domsson Sep 29 '17 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.