0

Tried to start my virtual machine on VirtualBox after a normal update on windows 10. But getting the issue

VT-x is not available (VERR_VMX_NO_VMX)

Before the update everything was working fine. Searching for the issue tells to enable virtualization in BIOS which I have checked is enabled.

Virtualization in BIOS

enter image description here

Hyper-V in Control Panel

enter image description here

Solutions I have tried

  1. Turning off Hyper-V with dism.exe /Online /Disable-Feature:Microsoft-Hyper-V-All following a reboot. but doesn't work.
  • @Biswa I have added the screenshot. Please check. – Nauman Zafar Sep 30 '17 at 13:38
  • 1
    Just Windows Defender – Nauman Zafar Sep 30 '17 at 13:52
  • @NaumanZafar May be you've to disable all the Hyper-V features. Put /all options in your dism command. Or disable all the Hyper-V features in Optional Features in control panel. – Biswapriyo Sep 30 '17 at 17:25
  • @Biswa Hyper-V is completely disabled from CP.. I have added the screenshot. – Nauman Zafar Oct 1 '17 at 6:36
  • 1
    I believe I must have confused. I flagged this as a duplicate due to the answer it recently received. Given this was asked in Sept 2017, Core Isolation is unlikely the culprit. When I see "answers" by extremely new users which I know are duplicates of an existing question's answer, I sometimes will flag the question, as a duplicate of the question with that answer. Instead of putting my foot in my mouth by submitting a comment. The flag was withdrawn. – Ramhound May 22 '18 at 16:58
0

Windows 10 Core isolation memory might be activated. This is stealing VT-x !

To see if it is activated check this:

Check Windows Defender

If you have this activated, deactivate it by setting the following registry key to 0

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard\Scenarios\HypervisorEnforcedCodeIntegrity\Enabled

|improve this answer|||||
-1

This was the reason for me "Windows 10 Core isolation memory might be activated. This is stealing VT-x"

I was messing around with my new surface pro 6 running win10 pro. Turned this off and my virtual box machines booted up just fine again.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.