11

Running Arch Linux, I've just updated the host (pacman -Syyu) and VMWare Workstation (14.0.0), and I now get the following error when I launch any VM no matter how many free memory I have or how many times I reboot:

Not enough physical memory is available to power on this virtual machine with its configured settings.
To fix this problem, increase the amount of physical memory for all virtual machines to 2130 MB or adjust the additional memory settings to allow more virtual machine memory to be swapped.
It is possible that native applications and/or services have locked down memory which could be preventing the virtual machine from launching. Shutting down unnecessary applications or services may free enough memory to launch this virtual machine.
If you were able to power on this virtual machine on this host computer in the past, try rebooting the host computer. Rebooting may allow you to use slightly more host memory to run virtual machines.

How to make it work?

  • Have you tried creating a new virtual machine, choosing the correct amount of memory, then linking your existing HDD to the new virtual machine? – Ramhound Sep 30 '17 at 14:56
  • Yes, it doesn't work as it seems. @Ramhound – J. Doe Sep 30 '17 at 15:01
  • So, do you have more than 2130MB of FREE memory on your host? What are the memory settings on the virtual machine? – Appleoddity Sep 30 '17 at 15:58
  • Yes. I require 4096MB, and I have more than 7000MB free. When I power off the VM I see that the memory is still consumed by a vmware process. @Appleoddity – J. Doe Sep 30 '17 at 16:11
  • 1
    @Ba7a7chy look at dude719's answer – J. Doe Oct 28 '17 at 9:23
21

I see you're on kernel version 4.13.3-1. This kernel has some small changes that require some patching for the Vmware vmmon module. Apply this patch to the vmmon module code to fix this memory issue:

https://github.com/mkubecek/vmware-host-modules/commit/770c7ffe611520ac96490d235399554c64e87d9f

cd /usr/lib/vmware/modules/source
tar xf vmmon.tar
cd vmmon-only/linux
vim hostif.c # or use the patch command to apply the patch
cd ../..
tar cf vmmon.tar vmmon-only
rm -rf vmmon-only # cleanup

# Lastly, we need to rebuild the patched module
sudo vmware-modconfig --console --install-all
| improve this answer | |
6

Run this comans on ubuntu 17 , work very well.

  1. sudo cd /tmp
  2. cp /usr/lib/vmware/modules/source/vmmon.tar .
  3. tar xf vmmon.tar
  4. rm vmmon.tar
  5. wget https://raw.githubusercontent.com/mkubecek/vmware-host-modules/fadedd9c8a4dd23f74da2b448572df95666dfe12/vmmon-only/linux/hostif.c
  6. mv -f hostif.c vmmon-only/linux/hostif.c
  7. tar cf vmmon.tar vmmon-only
  8. rm -fr vmmon-only
  9. mv -f vmmon.tar /usr/lib/vmware/modules/source/vmmon.tar
  10. vmware-modconfig --console --install-all
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.