1

I have a pc with Wndows 7 Professional (SP1) which has MS Office 2007 installed, but also appears to have come with Office 2016 preinstalled but unregistered (i.e. a limited trial please buy type of thing).

I don't know how or when exactly (not my pc, helping someone else) the file associations for Excel changed from Office 2007 to Office 2016, so excel files are opening by default in Office 2016. I can't find a way to change them back:

  • Excel 2007 does not show up in the "Open With" dialog for xlsx files.
    • Choosing browse and selecting C:\Program Files (x86)\Microsoft Office\Office 12\EXCEL.EXE just flat-out won't work. Even after selecting, Excel 07 still doesn't show up in the programs list and isn't selectable.
  • Word documents are still correctly associated with Word 2007; right clicking a word document has a hover/drop-down menu by "Open With" which gives me options for both Word 2016 and Word 2007. No such thing for Excel.

I haven't tried reinstalling (yet). I'm not sure if I can uninstall the Office 2016 entries, there's not an obvious entry for them in Programs under control panel. There is an entry for Office 365 with a similarly styled logo, so maybe that's it.

Excel 07 is still usable by launching it directly then choosing the file to open, but I still want to fix the file associations. If there's no other suggestions, I can try uninstalling both and only reinstalling 07.

  • 1
    The new format isn't retro-compatible You can't open the new format with the old 2007. – user772515 Sep 30 '17 at 19:29
  • 1
    that's part of the reason ".xls" changed to ".xlsx"... your other option is to save or convert the files as the earlier version before you get them on that machine... – Solar Mike Sep 30 '17 at 19:36
  • 1
    @MichaelBay Well, I don't know what to tell you. It says xlsx, but I can tell you that the program which says it's Excel 07 can definitely open the files in question because one workaround is to open Excel directly then open the file. I though the extension change was between (pre-?)2003 and 2007, from doc/xls/ppt to docx/xlsx/pptx, and the the XML format has stayed compatible since they introduced the tabbed UI. – zstewart Sep 30 '17 at 20:01
  • Uninstall both versions then install Office 2007 this will solve your problem. “There is an entry for Office 365 with a similarly styled logo, so maybe that's it.” - This means you have Office 365 installed not Office 2016. So you simply have the current Office offered by Office 365 – Ramhound Sep 30 '17 at 23:02
0

Instead of changing the association through the "Open With" dialog box, you can change it in Windows' Default Programs list, which should make it stick:

  • Open Default Programs from the Start menu or search bar
  • Select Associate a file type or protocol with a program
  • Scroll down to the .xlsx file type and select it
  • Click Change program...
  • Browse to your Excel 2007 installation
    (C:\Program Files (x86)\Microsoft Office\Office 12\EXCEL.EXE)
  • OK
  • Close

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.