I am using Firefox 56 and in versions prior to 56 there was an option under Options > Advanced called “Warn you when websites try to redirect or reload the page,” which blocked automatic website refreshes and redirects when selected. It showed a warning and a button to manually allow the refresh/redirect at the top of the webpage. I’ve had this option enabled for years.

Now that Firefox has “reorganized” the Options interface as of version 56, this option is no longer present and indeed the browser refreshes and redirections occur automatically once again.

How would one prevent automatic website refresh/redirects in Firefox 56?


In about:config, set accessibility.blockautorefresh to true.


  1. I typed "refresh" into about:config to see what could come up
  2. http://kb.mozillazine.org/Accessibility.blockautorefresh
  • Welcome to Super User. The link reflects Firefox V3, which is pretty ancient, and the page was last updated 6 years ago. You indicate you found the setting by searching your own about:config. The question is based on the structure having changed in V56. Can you edit your answer to add your version number, which will confirm that it applies? Thanks. – fixer1234 Oct 1 '17 at 3:02

A few updates later, in Firefox 64.0.2, I did something similar to MinebeaMitsumi's approach, and it worked.
Address bar: go to about:config
Search for accessibility.blockautorefresh
For me, accessibility.blockautorefresh was set to true by default.
I set it to false.

Now URLs for which Firefox would have previously popped up a "Firefox prevented this link from automatically redirecting to another page" message at the top now redirect without asking.

  • This is opposite to the action Mozilla describes for this setting. – fixer1234 Jan 26 '19 at 22:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.