7

I have tried plugging in several different USB devices (external hard drives and thumb drives), the problem is that they all show up under lsusb but do not show up using either fdisk -l or lsblk which is what I want to use to mount them.

  • same problem on 17.0.5 KDE edition on 2 different machines. – kyb Oct 6 '17 at 19:55
6

Here is a working solution.
In file /lib/udev/rules.d/69-libmtp.rules comment out the line

# Autoprobe vendor-specific, communication and PTP devices
ENV{ID_MTP_DEVICE}!="1", ENV{MTP_NO_PROBE}!="1", ENV{COLOR_MEASUREMENT_DEVICE}!="1", ENV{libsane_matched}!="yes", ATTR{bDeviceClass}=="00|02|06|ef|ff", PROGRAM="/usr/lib/udev/mtp-probe /sys$env{DEVPATH} $attr{busnum} $attr{devnum}", RESULT=="1", SYMLINK+="libmtp-%k", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"

Than you need reload udev rules

# udevadm control --reload-rules && udevadm trigger

But for me that was not enough, so reboot seems to be required.

Related themes and links:

  1. https://unix.stackexchange.com/questions/26842/mounting-usb-drive-that-is-not-recognized
  2. disable MTP udev rules for specific device so it can be mount as a USB Mass Storage device
  3. https://bbs.archlinux.org/viewtopic.php?id=119676
  4. https://bugs.launchpad.net/ubuntu/+source/libmtp/+bug/874293
  5. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=626010
  • I followed the answer in the link that said to add export MTP_NO_PROBE="1" – BlazePascal Oct 10 '17 at 6:16
0

I had the same problem after installation (in September 2019). After a few days, after a Manjaro update, everything started working correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.