5

i installed midnight commander by means of brew (brew install mc). But couldn't understand why it's in french. i've tried to reinstall it but it's turned out to be the same thing. Now i'm wondering how could i change the language to EN. Seems like there are no evident way to accomplish through GUI.

P.S. To let apply this alias persistently it's recommended to add this to .bashrc in other case the next time u start shell u have to type it again.

7

Try to make alias like:

alias mc='LANG=en_EN.UTF-8 mc'

On this way you will always run mc on English.   

  • Don't forget to restart your zsh/ bash – Vyacheslav Jul 23 '18 at 10:06
  • 1
    Still there's no clear reason why MC uses other than English in my case. I noticed it happens whenever I have another language in Systems Preferences -> Language & Region -> Preferred languages, even if English is set to Primary. – mato Mar 15 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.