2

I'm creating an all-day event in my personal Google Calendar, and am inviting myself on my work e-mail account to keep my calendars in sync for that event. I'm using Outlook 2016 on Windows 10 for the second account.

For some reason, Outlook thinks an "All Day" event is shifted 1 hour. Suppose an ICS with this info:

BEGIN:VCALENDAR
PRODID:-//Google Inc//Google Calendar 70.9054//EN
VERSION:2.0
CALSCALE:GREGORIAN
METHOD:REQUEST
BEGIN:VEVENT
DTSTART;VALUE=DATE:20171103
DTEND;VALUE=DATE:20171104
DTSTAMP:20171004T080944Z
....etc.

This shows up in Outlook like this:

When: vrijdag 3 novemeber 2017 01:00 to zaterdag 4 november 2017 01:00

What happens is that it's shifted exactly one hour, and in the "Month" view it would awkwardly show up on both Friday ("vrijdag") and Saturday ("zaterdag").

What I would like is for the event to show as an "All Day" event on Friday in Outlook too.

How can I get Outlook to behave?


More details about the reverse situation:

If I create an "All Day" event in Outlook and save it to ICS it would look like this:

BEGIN:VCALENDAR
PRODID:-//Microsoft Corporation//Outlook 16.0 MIMEDIR//EN
VERSION:2.0
METHOD:PUBLISH
X-MS-OLK-FORCEINSPECTOROPEN:TRUE
BEGIN:VEVENT
CLASS:PUBLIC
CREATED:20171004T082925Z
DTEND;VALUE=DATE:20171104
DTSTAMP:20171004T082925Z
DTSTART;VALUE=DATE:20171103
LAST-MODIFIED:20171004T082925Z
....etc.

In Google Calendar this does show up correctly as an "All Day" event.


Some info on my time zone settings:

  • Google Calendar says, when I click "Timezone" on an event that does have times, that I'm in the "GMT +02:00 (Amsterdam)" timezone.
  • Windows Date & Time says I'm in Time zone "(UTC+01:00) Amsterdam, Berlin...". Outlook Options under "Calendar" reports the same Time zone.
5
  • Just tested it on my GMT+2 (both google and Windows): Outlook shows google's all day events perfectly. It looks like something wrong with your Windows timezone. Is it possible that you've turned off daylight saving in Windows? – thims Oct 5 '17 at 18:26
  • @thims Thanks for confirming/checking. AFAIK I've got all defaults from my fresh install, just picked a time zone and nothing more. Will check more details on my laptop tomorrow. - On a related side note: where would you "turn on/off daylight saving"? – Jeroen Oct 5 '17 at 23:12
  • Right-click on the time/date part of the taskbar (bottom left corner of the desktop), select "Adjust date/time". There you'll see the "Adjust for daylight saving time automatically" setting. – thims Oct 6 '17 at 0:33
  • 1
    Jeroen, have you solved this? I'm having the same issue, only with a 2h shift. I always have time zones GMT and UTC while @thims only has GMT. – Felix Dec 10 '17 at 20:37
  • @Felix Nope, I unfortunately never found a solution, so I'm using the workaround instead :'( – Jeroen Dec 10 '17 at 22:07
2

I have had a related frustration for a long time and have come up with an easy workaround. I create all day appointments in my Google calendar and invite my Outlook calendar. Both calendars are set to US Eastern Standard Time (5 hours GMT). My all day Google appointments shift 5 hours in my Outlook or 6 hours during daylight savings time.

The fix: In Google, I now create appointments 12:00 a.m. on the day of the event through 12:00 a.m. the next day. I do not use the "all day" check box. This automatically includes the time zone when I send an invitation. When I accept these invites in Outlook, they correctly display in a single day.

-2

I had the same problem. The solution is to add the timezone information into the .ics file like this:

BEGIN:VTIMEZONE
TZID:W. Europe Standard Time
BEGIN:STANDARD
DTSTART:16011028T030000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:16010325T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
END:DAYLIGHT
END:VTIMEZONE

This should fix your problem and give you an all-day-event. Your event will now start at 0:00:00 and end there as well. You should obviously enter your preferred timezone if you are not in CET.

1
  • 1
    This is not really a solution. When a user sends a calendar invitation, they don't do so by editing the .ics file. Obviously, users can hand-edit individual invitations or calendar entries. The question is how to avoid doing that. – elixenide Jul 5 '18 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.