10

Chrome (v61 now) displays the full URL in the address bar if it is https, but fails to display the full URL if it is http.

How do I fix this?

| improve this question | | | | |
  • If you mean not displaying http:// before the URL, then there is likely no fix. If you are having another issue, you may wish to link to a screenshot or describe the issue in more detail. – Anaksunaman Oct 4 '17 at 19:36
  • Yes, cutting off the front of the URL. Any idea if there is a configuration option to reinstate the correct behaviour? – IanH Oct 6 '17 at 7:04
  • I won't say there isn't definitively, but to the best of my knowledge, the previous fixes for this behavior no longer work. As I understand it, Chrome intends to eventually mark all http pages as "non-secure" and this presentation decision seems to be intended to help highlight https over non-https pages. – Anaksunaman Oct 7 '17 at 6:42
  • 3
    Flagging as not secure makes sense, but displaying an incorrect URL has no logic at all. Other browsers have options to suppress such presentation choices. – IanH Oct 7 '17 at 8:01
9

This is now possible for Chrome 69+:

chrome://flags > Omnibox UI Hide Steady-State URL Scheme and Trivial Subdomains > Disabled

| improve this answer | | | | |
  • 2
    This is split into 3 settings now. For flags-search a "Omnibox UI Hide Steady-State URL" will match all three of them. – Jari Turkia Apr 5 '19 at 9:30
  • 7
    This doesn't work anymore in Chrome 79, all the "Omnibox UI Hide Steady-State URL" flags have been removed – Nicolas Dec 16 '19 at 9:35
  • Upvote for @Nicolas, downvote for Chrome. – Colin 't Hart Jan 28 at 10:11
  • 1
    @Nicolas a fix is now in the pipeline at last. – meuh Mar 19 at 12:37
  • @meuh good to know, thanks! – Nicolas Mar 21 at 0:56
2

As of Chrome 83, there is a flag for enabling a new context menu option "Show full URLs". chrome://flags/#omnibox-context-menu-show-full-urls

| improve this answer | | | | |
1

I believe the fastest way now to show the complete URL of a website is using a keyboard shortcut to give focus to the "omnibar" :

Ctrl + L

Alt + D

F6

https://support.google.com/chrome/answer/157179?hl=en

| improve this answer | | | | |
  • There are indeed workarounds using copy / paste or highlighting the URL, but it would be so much better if Chrome displayed the URL correctly in the first place. Other browsers get it right ... – IanH Feb 5 at 22:50
  • Yes it is highly unfortunate, I agree. – Moitah Feb 7 at 9:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.