2

I have an older Lenovo Thinkpad that I dual boot Win10 & Kali Linux on. I cannot get the "Creator's Edition" update to install. The error code I keep getting is 0x800703ed

So far I have:
- Ran ChkDsk /F /R
- Reset Windows Update Components via these instructions (though perhaps I missed a step since there are so many).
- Ran DISM.exe /Online /Cleanup-Image /RestoreHealth /Source:E:\ /LimitAccess (where E:\ was the Windows 10 mounted ISO)

I am out of ideas here. Any help appreciated. Thank you.

  • 1
    If you mount the current 1703 ISO while within Windows, and start the upgrade process, does it still fail? – Ramhound Oct 4 '17 at 21:07
  • 1
    uninstall any anti-virus or security and malware software's from the system reboot and try again. Also unplug anything that is not needed to boot like any printers usb anything etc. – vembutech Oct 5 '17 at 7:47
  • 1
    0x800703ed = ERROR_UNRECOGNIZED_VOLUME. so windows detects the linux partition where it tries to store temp files, but fails because windows doesn't understand linux file systems – magicandre1981 Oct 5 '17 at 15:18
  • Thanks, @magicandre1981. I was afraid that might be the case! :( I cannot get rid of my Kali install, so I will just have to live with this I guess. – KidACrimson Oct 5 '17 at 20:19
3

The error 0x800703ed means ERROR_UNRECOGNIZED_VOLUME:

//
// MessageId: ERROR_UNRECOGNIZED_VOLUME
//
// MessageText:
//
// The volume does not contain a recognized file system.
// Please make sure that all required file system drivers are loaded and that the volume is not corrupted.
//
#define ERROR_UNRECOGNIZED_VOLUME        1005L

Updating from a Windows 10 Build to a newer one is an upgrade like Win7 to 8. And here Windows always failed in dual boot situations with Linux. Backup the Linux, delete the Linux, update to (Fall) Creators Update 1703/1709, restore the Linux partition.

| improve this answer | |
  • This explains the cause of the issue, but provides no resolution or workaround. – KidACrimson Dec 21 '18 at 19:31
1

I had very similar situations several times, and each time it went away when I removed some external devices and removed my 4k screen.

So try to disconnect all non-elementary USB devices, and reduce your screen resolution to 1024x768. Then try it again. Once it is successfully installed, change the screen back to what you had, and plug everything back in, there should be no issues.

| improve this answer | |
  • Thanks, but not applicable to my case. – KidACrimson Dec 21 '18 at 19:31
1

SOLVED! This is what I did to fix the issue:

  • Created Win10 bootable USB installer with Rufus and latest Win10 ISO from MS
  • Booted to Win10 partition (which had the updating issue) -> DiskMgmt.msc -> marked System Partition as Active
  • Rebooted, this time using Win10 USB installer -> Advanced -> CMD prompt: ran all 4 BootRec.exe commands (/FixBoot /RebuildBCD, etc.)
  • Rebooted -> Win10 boots normally (Linux is temporarily broken or "missing" at this point due to GRUB bootloader being inaccessible by the machine)
  • Used EasyBCD to add Linux partition as a boot option in Windows BCD (you can also just use CMD prompt to do this, but I took the lazy route :P)
  • Booted to Win10 partition and updated Windows normally
| improve this answer | |
0

This is what worked for me. I suspected my BCD file was what was causing Windows update to always give me a "Something Went Wrong" message so I downloaded EasyBCD from Neosmart at www.majorgeeks.com/files/details/easybcd.html. (Other sites require you to download something called "Inbox" so I didn't use those sites.) I ended up also purchasing Easy Recovery Essentials from Neosmart for $19.95 because that is needed. I put EasyRE onto a USB thumb drive before running EasyBCD. I ran EasyBCD and deleted my BCD file. (The reason I deleted it is that I couldn't edit it so it was my only choice since I suspected that was the problem.) After deleting it I couldn't boot Windows so that is where the EasyRE was needed. I put in the thumb drive and rebooted. EasyRE booted right up and proceeded to install a new BCD. I restarted my PC and not only did it boot up but this time when I ran Windows update it worked. No error messages! I will note though, it did take almost and hour and a half to complete the year and a half of updates.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.