43

I recently upgraded to macOS High Sierra and VMWare Fusion Pro 10.

My Windows 10 Pro VM will no longer run. When I open it with Fusion, I see the following message:

"New Features are avialable for your virtual machine. To upgrade, power off this virtual machine and choose "Virtual Machine > Settings... > Compatibility"."

If I follow this instruction, VMWare says it cannot upgrade the machine till it is powered off; however, I can't get the machine to resume because: "Cannot find a valid peer process to connect to"

How can I fix this problem?

1
  • Since the topic is locked: For me the issue was rather that I had a keyboard extension Karabiner-Elements installed, which somehow interfered with VMWare, and I saw this error. After removing it and restarting my mac, the error was gone. Sep 20, 2018 at 14:51

7 Answers 7

83

With help from Daniel I was not able to find the solution although it took me a bit to find the right area. I have written up the process in detail below to help others resolve this issue. I found this problem often occurs when you do not allow this option during the VMWare installation or the dialog requesting this during the installation is no longer available (as was my case).

Here are the steps in detail

  1. Open System Preferences by searching in Spotlight or clicking the gear icon in the dock.
  2. On the top row there is an icon for Security and Privacy - Click that icon
  3. Near the bottom of the screen that appears following statement

System software from developer "VMWare, Inc." was blocked from loading

If you look to the right of this message. you will see a button marked Allow. Click the button and the message and the button disappear. Note you do not need to "unlock" elevated changing using the lock icon at the bottom for this to work.

10
  • Thank you, this helped me while nothing else on VMWare support forums did (they suggested rebooting and reinstalling the app, which I've done twice already).
    – mav
    Nov 14, 2017 at 15:23
  • 4
    THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU!!! :D
    – Bert G.
    Nov 20, 2017 at 18:27
  • If your "allow" button doesn't respond, use the touchpad that's physically built into your Mac. Apple has a set of very confusing security heuristics to try to block remote takeovers. In my case, the heuristic blocked my USB mouse physically connected to the computer. Apr 3, 2018 at 13:53
  • 2
    If the "allow" button doesn't respond, you might need to temporarily disable any third-party apps that generate or intercept keyboard events, such as QuicKeys, MagicPrefs, etc. Apr 5, 2018 at 4:41
  • Is there some way of determining which third-party apps are preventing the Allow button from working, though? This seems to be affecting me, but I'm on a new OS install with nothing but Chrome, Xcode (and command line tools), Visual Studio, VSCode, and Spectacle. I quit and disabled Spectacle, and it's still not reacting to clicks on that button.
    – patridge
    Apr 22, 2018 at 2:33
11

In my case I did not get the allow button to appear under the Security & Privacy General tab, no matter how many times I reinstalled or rebooted.

To fix it I enabled the "Allow apps downloaded from:" "Anywhere" option using the command:

sudo spctl --master-disable

Then after rebooting, the "Allow" button appeared.

1
  • I'm not sure if this directly helped my situation or not because I only restarted after issuing this command and it worked after restarting. I didn't need to click any "Allow" button, my OS just resumed where I left it at. Jun 22, 2018 at 15:35
4

On your Mac try:

"System Preferences > Security & Privacy > Allow VMware Fussion"

This resolved my issue. Hope it works for you!

1
  • This is correct answer. Jul 19, 2018 at 22:37
1

Snap Shot's answer solved it for me, but just to clarify: after clicking the Security & Privacy icon in System Preferences you need to ensure the General tab is selected to see the 'blocked' message.

1

For some this may be a serious and nasty bug.

It appears that after a while, you'll exhaust your options and you'll come across this once again after you've allowed the software in preferences, after you've run sudo spctl --master-disable and after everything you've tried that you've found on the internet. That's what's happened to me.

Quick background: I'm a developer that works on hybrid projects and the .NET stack running a windows machine in my mac, so my setup is more intensive and requires Visual Studio, git, npm, node, all that stuff installed on the vm os system as well as my mac system. My mac system version as of this writing: Mojave 10.14.5 (18F132), Fusion pro 10.

I'm not sure what the technical issues are for the bug but I know it has something to do with accessibility, and also that VMWare says the ball is in Mac's court to fix it. I know that it triggers when I suspend my vm on my host and unplug my monitors at work and plug in new monitors at home then go to open it back up again. It will glitch and cause this error and there's nothing I can do about it except completely uninstall and reinstall VMWare fusion with restarts, sometimes multiple times and can take up to at least an hour to fix.

I dealt with this for the last 6 months or so by having to completely uninstall/restart/install the application and it's been brutal. I put in a ticket to VMWare to address it a while ago, that's why I know they think it's Mac's job to fix it. They said to me they were in communication with Mac in regards to this issue, that it's already a known issue at this time. The last mac update appears to have mitigated the issue some, but I still ran into this issue when I unplugged a monitor WHILE VmWare fusion was suspending so it still exists.

For those of you who may be at your wits end, a reinstall is your only option, and that includes a full restart and may include having to be hooked up to the monitors and other peripherals that you last had your vm working on if you frequently move your computer around (like in my case a macbook pro from home to work). Yes, it's that strange. Below is my todo list:

  • Go back to the environment where your vm was last working
  • Hook up the peripherals you had connected to your mac when your vm was working (including extra monitors). (Why? Because when I did this exact procedure outside of the environment it was last working on, it would not work. I had to do multiple reinstalls and eventually just went back in for it to finally take. Yes it was that ridiculous.)
  • Delete the VMWare Fusion in /Applications
  • Run the script below in your terminal:
# Reset VMWare Fusion when it explodes again
# What the script above does is remove all the references to the vmware application itself.
# It does not affect your vm but of course double check your vms aren't located in any of these directories, it shouldn't be by default.
sudo rm -rf /Library/Application Support/VMware
sudo rm -rf /Library/Application Support/VMware Fusion
rm -rf /Library/Preferences/VMware Fusion
rm -rf ~/Library/Application Support/VMware Fusion
rm -rf ~/Library/Caches/com.vmware.fusion
rm -rf ~/Library/Preferences/VMware Fusion
rm -rf ~/Library/Preferences/com.vmware.fusion.LSSharedFileList.plist
rm -rf ~/Library/Preferences/com.vmware.fusion.LSSharedFileList.plist.lockfile
rm -rf ~/Library/Preferences/com.vmware.fusion.plist
rm -rf ~/Library/Preferences/com.vmware.fusion.plist.lockfile
rm -rf ~/Library/Preferences/com.vmware.fusionDaemon.plist
rm -rf ~/Library/Preferences/com.vmware.fusionDaemon.plist.lockfile
rm -rf ~/Library/Preferences/com.vmware.fusionStartMenu.plist
rm -rf ~/Library/Preferences/com.vmware.fusionStartMenu.plist.lockfilea
  • Restart your computer
  • After boot, go to your vmware personal account on the internet, download the vmware fusion installer again.
  • Open up and install it
  • DO NOT OPEN YOUR VM OR YOU MAY HAVE TO REPEAT THIS PROCESS AGAIN. After installing vmware fusion, restart your computer again.
  • After restart you should be able to open up your vm once again.

Hope this helps. If for some reason this doesn't work, make sure you are at the last place your vm worked with whatever peripherals you had plugged into your mac on again. That might sound strange but this low level bug issue is a strange and painful bug so don't take any chances having to uninstall/reinstall/restart multiple times before you finally get it working again.

POST CATALINA UPDATE

It appears that the Catalina update for MacOS fixes the issue. Whenever I boot up my VM, it now asks twice if I want use the software and it works every time. I haven't come across this issue since the update and I've been using it everyday. The update is still pretty fresh, only a couple weeks old so if I run into the issue again, I'll update this thread. So far though, no problems.

0

VMware Fusion Pro 10 will not run on imacs built before 2011, that was the issue I had with the new Fusion 10. I was able to downgrade and install Fusion 8 on my imac and it ran great. VMware wont give any money back when you downgrade though.

0

There was no way I could trigger the system extension confirmation dialog. What helped me the following:

  1. To check the VMware Developer ID, run the following command in Terminal

    $ sqlite3 /private/var/db/SystemPolicyConfiguration/KextPolicy '.dump kext_policy'

        PRAGMA foreign_keys=OFF;
        BEGIN TRANSACTION;
        CREATE TABLE kext_policy ( team_id TEXT, bundle_id TEXT, allowed BOOLEAN, developer_name TEXT, flags INTEGER, PRIMARY KEY (team_id, bundle_id) );
        INSERT INTO kext_policy VALUES('EG7KH642X6','com.vmware.kext.vmci',1,'VMware, Inc.',1);
        INSERT INTO kext_policy VALUES('EG7KH642X6','com.vmware.kext.vmnet',1,'VMware, Inc.',1);
        INSERT INTO kext_policy VALUES('EG7KH642X6','com.vmware.kext.vmx86',1,'VMware, Inc.',1);
        INSERT INTO kext_policy VALUES('EG7KH642X6','com.vmware.kext.vmioplug.17.1.3',1,'VMware, Inc.',1);
        COMMIT;

'EG7KH642X6' is the ID.

  1. Shut down the macOS, and enter in Recovery mode using CMD+R

  2. Open the Terminal, and run the following command

    $ spctl kext-consent add EG7KH642X6

  3. Exit Recovery mode, and reboot the macOS

Credits to https://communities.vmware.com/message/2740189#2740189

Not the answer you're looking for? Browse other questions tagged or ask your own question.