0

I am trying to switch screen resolution with xrandr. I have output the available modes with xrandr -q which output:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 346mm x 194mm
   3840x2160     60.00 +
   2048x1536     60.00  
   1920x1440     60.00  
   1856x1392     60.01  
   1792x1344     60.01  
   1920x1200     59.95  
   1920x1080     59.93* 
   1600x1200     60.00  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1360x768      59.80    59.96  
   1152x864      60.00  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   960x600       60.00  
   960x540       59.99  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   800x512       60.17  
   700x525       59.98  
   640x512       60.02  
   720x450       59.89  
   640x480       60.00    59.94  
   680x384       59.80    59.96  
   576x432       60.06  
   512x384       60.00  
   400x300       60.32    56.34  
   320x240       60.05  
DP-1-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-1 disconnected (normal left inverted right x axis y axis)
DP-1-2 disconnected (normal left inverted right x axis y axis)
HDMI-1-2 disconnected (normal left inverted right x axis y axis)

As you can see I am currently on 1920x1080, I am trying to switch to the preferred resolution of 3840x2160. So I try to switch:

$ xrandr -s 3840x2160
Size 3840x2160 not found in available modes

I've tried switching by index:

$ xrandr -s 1
Size index 1 is too large, there are only 1 sizes

I tried adding the screen name with --screen 0: but that doesn't change the result.

Am I missing something or am I doing anything wrong?

  • Standard debugging tip: does it work w/ other resolutions? I notice that 3840x2160 has a "+" in the xrandr -q list, whereas most of the other resolutions don't. Try some other resolutions and narrow it down. – barrycarter Oct 7 '17 at 22:41
  • Nope, none of them work (except 1920x1080, but that just flashes the screen). + means preferred resolution of the display (so usually the native one) – user2117418 Oct 8 '17 at 9:35
  • Try xrandr -q --verbose but I'm just guessing at this point. You may also mess around with xrandr --rate, since 59.93 seems like an unusual refresh rate. – barrycarter Oct 8 '17 at 12:09
0

Well, I figured out what I was missing, it needed --output eDP-1-1. Still not quite sure why that isn't implied and what was operating on when I left it out, but it works now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.