0

I'm using Windows 8.1.

Currently, I set Window update to: Never check for updates (not recommended)

Control Panel\All Control Panel Items\Windows Update\Change settings

I realize that the rundll32.exe & wicainventory.exe slow my computer down (it both uses 100% disk usage, especially, rundll32.exe use 100% Memory (up to 3GB)) after I install an add-on (HLSL Tools) for my Visual Studio 2015 (maybe it's a co-incident).

Anyway, here's how rundll32.exe & wicainventory.exe slow down my PC.

Stage 1: rundll32.exe uses a lot of my PC memory (3GB) & disk usage (100%). At this time, wicainventory.exe doesn't use much of my PC resource. In another word, rundll32.exe is abnormal, wicainventory.exe is normal.

Stage 2: After a while, rundll32.exe doesn't use much of my PC resource. But this time, wicainventory.exe use a lot my my PC resource - It makes my disk usage up to 100%. In another word, rundll32.exe is normal, wicainventory.exe is abnormal.

Stage 3: After a while, my PC back to normal. (rundll32.exe is normal, wicainventory.exe is normal).

This (stage 1,2,3) happens repeatedly on my PC (about a few day it happens again). When this happens, I can't play game so it really annoying.

This could be wicainventory.exe installs something on my PC behind my back. Is there anyway to find out what it is doing behind my back.

Thanks for reading :)

  • Just curious if you manually ran Windows update and got all it's updates. Also there are a few updates to VS2015 that you may want to download and install. – ajawad987 Oct 8 '17 at 5:21
  • 1
    disable the idle/automatic maintenance tasks in task scheduler – magicandre1981 Oct 8 '17 at 7:29
  • @ajawad987: I used to let Windows update install update for me, but that's soon annoying me very. So now if I wanna install a update for security, I just go to Microsoft page and collect the update and install it manually. – 123iamking Oct 8 '17 at 9:57
  • @magicandre1981: Come to think of it, the automatic maintenance task maybe the trouble here. Thank magicandre1981 :) I try it now. – 123iamking Oct 8 '17 at 9:58
  • 1
    disable all of them and you're fine – magicandre1981 Oct 8 '17 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.